I'm out visiting some family at the moment and my dad has found some cheap Android tablets from somewhere, the Neuropad Ultra. They are not great, but they do the job and you can give them to the kids to play with as they're nice and cheap.

Anyway, a new one got delivered today so we have two in the house now. We tried to connect it to the internet without much joy. A little digging around and I find that they both have the same MAC address!

So I've been searching Google trying to find a solution but nothing I find seems to work. I tried some commands I found including some busybox stuff, but nothing is working.

Has anybody any ideas or managed to get it changed on a similar device?

It's using Android 4.0.3

Thanks in advance!

  • Interesting.. What a coincidence!!! :-) Jul 3 '12 at 3:56
  • All the pieces are shipping with the same MAC address or what? I guess it should be rooted to spoof the MAC Jul 3 '12 at 5:14
  • Well I guess that the distributer is using some sort of underhand mass producing techniques to get them made as cheap as possible. I'm not sure exactly. It is already rooted, but none of the commands I find work. I've been using several versions of the ifconfig command. I followed the instructions at the following page with no avail .. android.stackexchange.com/questions/17657/…
    – Doyley
    Jul 3 '12 at 7:49

Your mentioning of busybox use let's me assume your device(s) is/are rooted, so you could give the Wireless MAC Changer a try. Didn't try it myself, though, as I have no need to ;)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.