I have quite an old mobile phone Asus Zenfone 4 Max (ZC520KL, X00HD_4) with Android 8.1.0. When starting, it asks for the schema to unlock then it restarts indefinitely, showing some recovering options (try again or restart).

  • I restarted with the volume down + power buttons to have further recovery options.
  • I have tried to wipe the cache partition before restarting, without any success.

I would like to avoid wiping data as I received my new mobile phone the day of the old one's crash. I would like to recover data.

If I run graphics tests, the test is failing (I have no further details). Last_logs file is showing this error:

Libc: access denied finding property ro.sf.lcd.density W:Failed to read max brightness: permission denied

/soc/qcom,cam_smmu/msm_cam_smmu_cb1: could not get #iommu-cells for soc/qcom,iommu@1e0000

Is there any way to fix this issue? Is there any hidden shell that I could run on the mobile to set the missing parameter and maybe make the mobile start? I cannot install any application as I cannot start the mobile.

If not, is there any way to copy the data from the mobile to the computer? I cannot go further than the recovery menu.

I would like to avoid running a factory reset not to lose data, but if I have no choice, is there any way to recover the reset data?

I have no Google recovery, nor SD card in the mobile as it was not detecting it for a few months. It seems the debug mode is disabled as adb devices does not show anything. I don't know how to use fastboot correctly.


Unfortunately, I have wiped data by running a factory reset. I think I have lost the last 2 years photos without any possible recovery. If someone could confirm or not, as I could continue hoping or not


You must log in to answer this question.