0

I tried mounting the ext4 partition as root, but it didn't work. My phone is rooted, but as it seems no one has managed to do what I want to do. I couldn't find any solution, that worked for me. How can I mount the ext4 partition?

What I have tried so far:

  1. Manually mounting the partition. I tried running mount -t ext4 /dev/block/sda2 /mnt/media_rw/usbotg, but that doesn't work and outputs mount: '/dev/block/sda2'->'/mnt/media_rw/usbotg': Invalid argument. I was trying this, because of this answer - https://android.stackexchange.com/a/220020.

  2. I also tried using vold-posix, but for some reason Magisk fails to install the module and shows Unable to unpack boot image, even though it is able to install Magisk updates on the boot image.

14
  • Please tell us explicitly what have you tried so far. And how it did not work for you. What error are you getting? What are you trying to achieve? Jul 12, 2023 at 13:10
  • @IrfanLatif I added additional information.
    – RadoslavL
    Jul 12, 2023 at 17:22
  • Invalid argument is a general error. Run strace mount to get detailed log. Jul 13, 2023 at 8:28
  • @IrfanLatif I couldn't copy everything, but here are the last lines, that I think might be relevant - pastebin.com/CS2FE1xS. (65F0-14E9 is my SD card)
    – RadoslavL
    Jul 13, 2023 at 8:50
  • I meant strace mount -t ext4 /dev/block/sda2 /mnt/media_rw/usbotg. Syscall tracing of the failing command. Jul 13, 2023 at 10:33

0

You must log in to answer this question.

Browse other questions tagged .