Every few weeks, when I go to type something, I find that the Swype dictionary has been deleted (or at least can't be accessed) for no apparent reason. This kills the 2 benefits of Swype: typing without lifting your finger, and predictive word completion (and correction). Without these 2 features, Swype becomes much harder to use, and I find I'm better off with the standard keyboard.

So the question is, why is this happening, and is it possible to fix without re-installing Swype? (I've been able to fix this in the past by re-installing Swype, but that's a pain in the butt.)

  • What causes the dictionary to delete? are you removing your sd card? does the app live on your phone memory? Is the dictionary just gone as in no file or is it just cleared of data? Nov 9, 2010 at 18:30
  • I don't know what causes the dictionary to be deleted. That's part of the question. The dictionary may be stored on the SD card, but the app isn't. Also, it's not like I have a habit of removing the SD card, and I don't turn on USB mode all that often.
    – MBraedley
    Nov 10, 2010 at 22:52

6 Answers 6


So I was facing the same issue as well, and after getting no help from internet and forums, I contacted swype, here is the reply I received from them. I have not tried it yet, but I expect it to work.


This is, unfortunately, a known issue with the beta on some devices; it is particularly prevalent on the HTC Incredible, and occurs specifically after a reboot of the device (though it can, in rare occasions, occur at other times). The issue is related to a feature of some phones known as “fastboot” which is designed to bring the system into a usable state faster by delaying the start of some system functions until after the system has been made ready for user interaction. In our case, the ESN variable (a hardware identifier tied to the telephony radio) is not loaded into memory until after Swype has already started loading. This value is needed to verify Swype’s license, and so Swype’s licensing mechanism fails.
The workaround for this issue is to switch the input method off of Swype, type a few characters with another keyboard, then switch back to Swype. This will trigger Swype to reload the license. To do this, simply long-press on any text input box, choose “Input Method”, and select an alternative keyboard. Type a few characters then use the same procedure to switch back to Swype. I hope this helps relieve the frustration of having to reinstall Swype all the time. It’s not a perfect solution, but it’s much better than reinstalling



Are you rooted? If so, you might try using an app like Titanium Backup to take a snapshot of a good install with dictionary, and restoring that whenever the problem resurfaces.

Unfortunately, I don't have any direct solution to the problem - haven't encountered that.

  • No, not rooted. I'm not sure if the backup would capture the dictionary either.
    – MBraedley
    Oct 30, 2010 at 17:15
  • The backup does capture the dictionary, but only if you use a root backup app that includes the /data partition. Non-root backup apps only capture the apk, which won't get the data.
    – Saiboogu
    Oct 30, 2010 at 23:44

I'm not sure, but I think that when the SD card is mounted by a computer through USB the phone can't access it. I'd hazard a guess that you used the keyboard while you were plugged into the USB and swype couldn't get at it's dictionary so it started a new one which was saved to SD once USB was unplugged.

That could be worth an experiment.


Are you using any memory management programs? Any app2sd, battery savers, task killers, etc. -- basically anything that might cause an irregularity? If so, I suggest turning them all of for a few weeks, see if that makes any difference.

  • I am using App2SD and a task killer, but as stated earlier, the app still resides on the phone, and is not able to be installed to the SD card, and I have my task killer set up to exclude Swype. I don't think either of them would be causing my issues.
    – MBraedley
    Nov 11, 2010 at 23:10
  • From what I understand (I don't have swype, but just did some googling for you) you can set swype to use android's built in dictionary system. If this doesn't solve the issue, then you will know there is some larger factor at work.
    – ryanklee
    Nov 11, 2010 at 23:34

I'm using an older version of Swype, 1.3.x., which came pre-installed on my Samsung Galaxy S2. Now running JellyBean, I was facing the same problem. This is how I managed to fix it:

  1. I force-stopped the app
  2. then cleared all data through android application manager
  3. then disabled the app.
  4. Then I enabled the stock keyboard for a bit and then tried re-enabling the app and choosing it as the input mode.

I had to go through the registration again, but my dictionary sure came back ! Try it!


I have a HTC one M7. It decided to reboot after getting confused on how much battery power it had. Now the personised Swype dictionary is gone. I tried Swype's workaround listed above, but no success. There is no footprint of my old dictionary. However I have found that it's easy to back up my new personal dictionary. In: Settings> Language & Keyboard> HTC Sense Input> Personal Dictionary> then go to tip right ':' Backup to Email. It will then save your dictionary as an attachment on email, which u can download & it will automatically recognise it upon opening & install it for you. How this will save people from the troubles I've had.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .