(I have already looked up many solutions (involving apk-managers or un-/reinstalling) offered in similar situations but none of them seemed to work in my case.)

When trying to update the app "Google Play services" (microG Services Core, com.google.android.gms) I get the error message "Conflicting package exists". Meanwhile other apps are complaining that Google play services are not up to date. I am at a loss because I cannot uninstall this app, and solutions using apkmanagers have also failed, perhaps due to not having root access. I also tried installing the Google play services apk from apkmirror sites, but the installer would simply say that the app could not be installed.

I am open to more radical solutions like a factory reset, but I want to be sure that would even help before I do. I have adb tools on my laptop.

I have a mostly degoogled phone (e/OS) and usually use F-Droid for my apps, and aurora store for apps (such as this one) that cannot be found on F-Droid. I am trying to update Google Play Services through the aurora store. It has always worked so far, and other apps update normally. I think this issue might have happened while I was manually updating some apps and accidentally had two updates running at the same time? I'm not entirely sure.

E/OS has its own store but it has never really worked for me and I never use it. The e/OS store always claims that all apps are up to date.

  • 2
    Welcome to Android Enthusiasts. The question mentioned "microG Services Core" which is a replacement for the real Google Play Services, thus I'm not sure if updating the real Google Play Services is expected. On the other hand, microG recommends to update it using F-Droid. Have you tried it?
    – Andrew T.
    Aug 5 at 11:27
  • If you are degoogling your phone, why go to Play Store and why try and update Play Services? Aug 5 at 13:23
  • 1
    @beeshyams thanks, I did mention the things I tried in the next paragraph, but I edited to make it clearer. Aug 5 at 13:41
  • @RohitGupta just because I don't want my entire OS to be based and depending on google, it doesn't mean I might not want to use some apps for which Google services are required. Aug 5 at 13:43
  • @AndrewT. Thanks so much, I wasn't aware that the services could be updated through F-Droid. I checked and F-Droid installed its own microG core package. As soon as they were installed, it prompted me to update, and then the same error occurred: "Install Failed". I'm not entirely sure what happened but some of my apps are happy with this fix for now, perhaps I got a slightly newer version through F-Droid? But I am still unable to update to the newest version. Aug 5 at 14:10


You must log in to answer this question.

Browse other questions tagged .