0

I use the latest version of Nox Player (android emulator) on Mac OS Catalina.

I would like to mount my AFP or SMB drive to Nox Player.

I've connected to Nox Player thru ADB:

adb connect 127.0.0.1:62001

Now I am trying to mount the drive:

 mount -t afp afp://login:[email protected]/photo /sdcard/DCIM

(/sdcard/DCIM folder exists)

But it returns the error No such device. I tried to su before executing the command. I tried to mount to another folder (/mnt/sdcard/xyz, /storage/self/primary/DCIM), but it doesn't help.

The command given above works well if executed directly on my Mac. I've tried to ping 192.168.1.5 from Nox player and it works well. I've tried to open the same storage within Nox Player built-in Amaze file browser as SMB share and it also works.

I've read How to mount NFS on Android with correct permissions?, but it is not quite clear for me what else could be tried.

What should I try?

2
  • I don't think that Android contains the necessary drivers for AFP or SMB protocol as these are not needed by regular Android devices.
    – Robert
    Aug 21, 2023 at 10:23
  • @Robert, looks like the missing drivers/modules could be added manually, but the question is where to take them for Nox Player or how to compile it. What is about other protocols? Can I try to use NFS or something else?
    – LA_
    Aug 22, 2023 at 8:54

0

You must log in to answer this question.

Browse other questions tagged .