I have a Chainfire-rooted Samsung Galaxy J5 with Android 7.1. The $PATH variable is


But /system/sbin appears not to exist at all.

Why is this? Is it normal? Could the manual creation (and planned use) of this folder cause problems? (I run into huge ones, but not sure this was the cause.)

(I probably have made several mistakes, and I will post my questions one-by-one to avoid confusion. This is the first.)

  • You can put any directory on PATH. They don't necessarily need to exist. init sets the default PATH on boot. /system/sbin was removed in Android 11. Related: How to modify environment variables like PATH at startup? Aug 21, 2023 at 21:09
  • Thanks. It could be only a coincidence, but I run into troubles just after having created this folder. So I wanted to be sure if this could cause it. (lot of commands, like even "ls" stopped to function: "not found"...etc.)
    – martinist
    Aug 22, 2023 at 21:59


You must log in to answer this question.

Browse other questions tagged .