0

My Asus Zenfone 4 (ZE554KL) started to be slow and sometimes it crashed and restarted, and then it went back to normal. It stayed that way for months. Last week, the bar containing the buttons to access the apps disappeared, and the only thing I could access was the top bar, scrolling down, but I couldn't access anything except the Settings. In the Settings, none of the changes I made worked, and it always ended up crashing and restarting.

At a certain point, I decided to try starting in safe mode, so I pressed the shortcut and it worked. It started normally, but a few moments later it simply restarted, and right after the Asus logo screen, it fell straight to TWRP, on a screen asking for a password to decrypt and mount. I tried every possible password I've ever used on my phone but none worked.

I tried to cancel and go to File Explorer, and there I got a surprise: Internal storage was listed as 0 MB. I tried to connect my cell phone via USB cable to the PC, entering fastboot mode and only the SD card appeared (where I didn't save anything).

To recap the problems are as follows:

  • My Android does not start, it goes straight to TWRP asking for a password to decrypt and mount the data.

  • When I click cancel and try to access files through TWRP's file explorer, my phone's internal storage is listed as 0 MB.

  • When trying to enter fastboot mode through TWRP and connect the phone to the PC, only the SD card appears, where I never saved anything.

  • I need to save my WhatsApp data that is not saved in the cloud or locally, being just the application data and being all the most important work in my life, WhatsApp remains connected via WhatsApp Web, and I can only access recent messages, and I know that soon it will disconnect because my cell phone does not start Android anymore.

I saved important things on my WhatsApp, and as my cell phone's storage was always full, I never made a local backup, nor on the Google account because I didn't have any account with enough free memory (I had a lot of things saved, they exceeded 15GB). My WhatsApp is still connected through WhatsApp Web but I don't know for how long, and I can only access the most recent messages because the oldest ones can only be accessed through the cell phone.

6
  • 1
    Based on what you describe the flash memory of your phone could be defect. As your phone is about 6 years old flash memory problems are reasonable.
    – Robert
    Sep 4, 2023 at 15:38
  • Yes... something solution?
    – Mr. Stevan
    Sep 4, 2023 at 15:58
  • Sorry but that is difficult to answer. For example it is not clear if your device uses hardware encryption or not thus if it would be possible to decrypt the data only with your password/PIN. If that would be the case you could try to make an image of the user data partition and try to decrypt the data on a Linux PC.
    – Robert
    Sep 4, 2023 at 16:17
  • As I mentioned, when plugging in the usb cable, the internal storage does not appear, and TWRP does not appear either, but I believe it is due to the encryption, I believe it is the default encryption of android, I already tried to type my pin but it did not work. My pin has zeros and it was numerical, I saw in other forums that there is a problem with typing zero in twrp, but I didn't understand the reason. Is there a way to make a nandroid or internal storage backup image? Or at least manage to copy WhatsApp folders to restore conversations on a fresh android installation?
    – Mr. Stevan
    Sep 4, 2023 at 16:24
  • Have you tried TWRP support, they may have suggestions. Sep 4, 2023 at 20:32

0

You must log in to answer this question.

Browse other questions tagged .