I'm trying to use scrcpy on Ubuntu 22.04 with a Samsung S22 Ultra connected wirelessly via ADB. However, when I run the command from the PC's terminal, the program starts, and everything works correctly for a few seconds. Then, the transmission pauses without any error message in the terminal where the process is running; the video simply freezes (if I interact with the smartphone's screen, it works correctly, but the screen changes stop being displayed on the PC).

After this error occurs, when I run a command like 'adb devices,' the device is now listed as 'offline.' The only way to reconnect to the device via ADB is to restart the PC and the device.

This issue only happens when using this particular device. When I use any other phone (e.g., Nokia 2.3 with Android 11), the connection works correctly both wirelessly and with a USB cable.

Furthermore, this error only occurs when the ADB connection is wireless. If I make an ADB connection via USB, scrcpy works correctly on the same PC.

On Windows, the program works well both wirelessly and with a USB connection.

My PC, where I encounter this problem, is running Ubuntu 22.04. The device in question is a Samsung S23 Ultra SM-S918B with android 13.

The scrcpy version is as follows:

scrcpy 2.1.1 <https://github.com/Genymobile/scrcpy>

Dependencies (compiled / linked):
 - SDL: 2.0.20 / 2.0.20
 - libavcodec: 58.134.100 / 58.134.100
 - libavformat: 58.76.100 / 58.76.100
 - libavutil: 56.70.100 / 56.70.100
 - libavdevice: 58.13.100 / 58.13.100
 - libusb: - / 1.0.25

Ubuntu Version:

Distributor ID: Ubuntu
Description:    Ubuntu 22.04.2 LTS
Release:    22.04
Codename:   jammy

kernel version:


Any suggestion is welcome. Thanks


You must log in to answer this question.

Browse other questions tagged .