I am keep on getting this pop-up every 30 sec. I searched on the internet, and most of the solutions are to play with the charging pin.

It's also showing it's charging when it's not. My phone thinks it's charging

I think this has to be a software issue.

Does anyone have any solution?

  • 1
    Granted the timing is coincidental, but have you investigated the charging pin as you and the linked previous question mention? That seems to be the solution for many people, OS upgrade or no.
    – Mr. Buster
    Jul 11, 2012 at 0:45
  • @Mr.Buster I have observed the same thing, replacing the USB resolves the problem, but I do not see any point in doing that, because software upgrade triggered it so I suspect that it should be software problem, and Stack Exchange is the place I can trust people. Hence, question. Jul 16, 2012 at 22:21

4 Answers 4


Short answer:

That's no doubt a software issue, reported across forums after an upgrade to ICS 4.0.x.

Some users reporting this can be found here:

Don't know with certainty if you've upgraded the firmware to ICS 4.0 or any other variant, being the latest ones 4.0.3 or 4.0.4

Nonetheless, you either roll back and wait for a new version that doesn't cause that issue or you can try some of the suggestions provided below (all reported to have worked without problems by other owners of a Samsung Galaxy S2).

Extending the answer:

First and above all

Backup all personal data on your phone to make sure you are not going to lose anything either by rolling back or trying a new/different firmware.

e.g., contacts, SMS, MMS, Internet settings, Wi-Fi passwords, etc...

You can go with one of these suggestions:

Once the backup is concluded, the following solutions are documented as to have solved that particular issue on your phone. Solutions ordered from the simplest to the most complicated:

  1. Clearing cache data

    The problem you're facing can be related to old files still in cache. Follow these steps to clear your cache and see if it solves it:

    1. Boot your phone in recovery mode, to do that press and hold VOLUME UP and MIDDLE KEY, while holding both press POWER ON;

    2. You will see your phone booted in recovery mode , in recovery mode touch screen will not work so use Volume UP and Volume Down to navigate through options and MIDDLE KEY to confirm;

    3. Choose “wipe cache partition” from menu;

    4. It will clear the cache data;

    5. Now select reboot system now;

  2. Factory Reset

    Samsung has a master reset code used to factory reset your phone. You can try this as to cleanup your phone and wait for a better ICS version, or try another ICS version (see suggestion n.º 3):

    • Make sure you have a backup of your personal data (e.g., contacts, SMS, MMS, Internet settings, Wi-Fi passwords, etc).

    • Take your SIM and memory card out of your phone

    • Turn your phone back on, and wait for the dial pad

    • Dial the factory reset code: *2767*3855#

    This will wipe, reset and then correctly format the internal storage. After the process is completed, place your SIM and memory cards back on the phone.

  3. Firmware Flash (Odin)

    Download the Latest Samsung Odin here, and install either one of the latest ICS versions or a previous one that can be found on the links at the very end of this answer.

    3.1. flash your firmware to the Android 4.0:

    • XXLPQ — Update Galaxy S2 to Android 4.0 Official Firmware Manually

      This firmware and the guide below is compatible only and only with Galaxy S2, model number i9100. It’s not compatible with any other device, including US variants of S2, the Epic 4G Touch, T-mobile Galaxy S2 and AT&T Galaxy S2 along with Skyrocket. Check your device’s model number in Settings » About phone.

    3.2. Install Android ICS 4.0.3 XXLPJ Firmware Update:

    • Install Android ICS 4.0.3 XXLPJ Firmware on Samsung Galaxy S2 GT I9100

      Here is another tutorial how to Install Android ICS 4.0.3 XXLPJ Firmware Update on Samsung Galaxy S2 GT i9100. Samsung Galaxy II got the Official XXLPQ Firmware update recently. But the Firmware had some bugs and users reported it. Samsung revived the Android 4.0.3 and added some other latest features

    3.3. flash your firmware to the Android 4.0.4:

    • XXLQ5 - Download & Install Official Android 4.0.4 ICS Firmware for Samsung Galaxy S2

      Finally, you can download and install latest official Android 4.0.4 Ice Cream Sandwich Firmware on Samsung Galaxy S II now. Yup, there is a leaked official Android 4.0.4 ICS Firmware for Samsung Galaxy S2 ~ XXLQ5 Firmware (Europe region).

    • Update Samsung Galaxy S2 I9100 to Android 4.0.4 ICS XXLQ5 Leaked Firmware

      Samsung Galaxy S2 I9100 has been running on the Android 4.0.3 firmware and recently there were rumors that said that it won’t receive the Android 4.0.4 ICS update. However, all these rumors were shattered today because there is a new leaked firmware for I9100 that is based on Android 4.0.4 ICS and with XXLQ5 firmware, which means that Samsung should eventually launch the new update in the near future.

Useful and related links:

  • I'd recommend Heimdall instead of Odin - Odin is leaked software and Heimdall (it's Free Software clone) is available in source code form.
    – Broam
    Jul 16, 2012 at 19:26
  • @Broam I did not know Heimdall! I like it already, is cross-platform, available for Windows, Linux and Mac OS X. Tks for the recommendation :)
    – Zuul
    Jul 16, 2012 at 20:13
  • @Broam I've only used Odin and with no issues so far! I'll give a go to Heimdall as soon as an opportunity arises.
    – Zuul
    Jul 16, 2012 at 20:14
  • @Zuul, thanks for the detailed answer! I am going to try that today, will let you know the feedback! Jul 16, 2012 at 22:16
  • It got fixed by itself! Aug 1, 2012 at 18:53

I don't own a Galaxy SII. However according to this thread it seems the problem lies in the USB port as when it is replaced the issue has been resolved.

  • I had the same problem with the charge error being reported incorrectly. I bent the USB port slightly upwards towards the screen and the charging problem disappeared. A temporary fix until I can replace the port.
    – user20296
    Sep 16, 2012 at 12:20

I went to Sprint yesterday because all of a sudden I'm having this frustrating problem.

I was told that it is a software issue and nothing more. An email from the higher-ups directed techs not to switch out phones because the problem is going to persist (until Samsung fixes the software).


With mine, clearing dust out of the USB port with a pin and then plugging a charger in and out a few times fixed the issue.

So it's not necessarily a bug in the software. Perhaps Android OS 4.0.x has a new feature to detect and report voltage problems when charging, while previous versions did not (and any software "fix" will just disable this feature).

  • 1
    +1, Cleaning the USB port with air and a pin worked for my wife's phone as well. Aug 19, 2013 at 2:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .