1

I'm new to the Android world when it comes to these matters, so I ask for your patience if I say something wrong.

I have a Motorola Moto E5 Plus cell phone and I used my Linux Ubuntu to help with the commands. With all the tutorials I've seen, basically what I did was:

  1. I downloaded the TWRPAPP APK, transferred it to my cell phone and installed it;
  2. I ran the application and downloaded the latest version of TWRP (3.7.0_9-0-hannah):
    1. NOTE: After downloading the image, I also transferred it to my computer.
  3. I activated USB debugging and OEM unlocked;
  4. I restarted the phone into the bootloader with: adb reboot bootloader
  5. I unlocked the bootloader:
    1. I got information from the OEM: fastboot oem get_unlock_data
    2. I registered on the Motorola website and got the unlock key and executed: fastboot oem unlock <key>
    3. Everything went well and the bootloader was unlocked...
  6. Back at the bootloader screen, I started TWRP with the command fastboot boot twrp.img (as it was the only way I could get it to start);
  7. And now the problem begins...
  8. When TWRP finishes loading, the first screen asks for a password to decrypt:
    1. I didn't really know what that password was. When I researched, I understood that this password was the same password to unlock the cell phone when it is on, however, the cell phone did not have a password.
    2. So I clicked "Cancel" on the start screen and it continues to enter TWRP but on the logs screen it shows mounting errors and that was bad because I couldn't see anything inside the phone's folders and consequently I couldn't see the zipped image to flash.
    3. From the tutorials I verified that I needed to: Wipe > Advanced Wipe > Check "Data" > Swipe to Wipe
    4. Then return to the main menu: Wipe > Format Data > Type "yes" > Press Enter Button in Keyboard

After that I restart in TWRP and in fact I no longer have any password to enter and it even goes directly to the main menu, however, I also no longer have the GSI image that I downloaded.

PS: After all these things I tried to use OTG but I also couldn't get it to be recognized in TWRP.

4
  • Unlocking the bootloader by design erases all data. And in addition you wiped your data partition so everything you had downloaded is long gone.
    – Robert
    Oct 15, 2023 at 16:30
  • So, I didn't mention it, but after unlocking the bootloader I moved the zipped image to the Download folder. Regarding wiping the participation, this was the only solution I found to be able to decrypt it, but as you mentioned, the data is lost, however, if I turn the device on again to place the zipped image in the Download folder (now with the partition already decrypted), Android itself will start at factory defaults (after all, it was wiped) and I see that during the boot process, Android encrypts the partition again :/
    – rhuanpk
    Oct 15, 2023 at 17:10
  • You can try to directly flash the image from the PC using adb sideload when TWRP is in sideload mode.
    – Robert
    Oct 15, 2023 at 18:10
  • Well, in the end the sideloading process didn't load but I solved the main problem by moving the image to MicroSD and I was able to flash the image. Unfortunately, after that (and for other reasons) now no system starts... I even wanted to continue the subject here but as I thought this was another problem not related to this topic, I created this other question.
    – rhuanpk
    Oct 16, 2023 at 2:44

1 Answer 1

0

In the end, the sideloading process didn't load, but I solved the main problem by moving the image to MicroSD and I was able to flash the image.

Unfortunately, after that (and for other reasons), no system starts.

Follow-up: No Operacional System Android is Installed

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .