Recently I created/removed some folders on Outlook desktop app.

When I synchronized my corporate account by manually refreshing under the folders screen, it didn't bring the new folders, nor removed the removed ones.

Is this a known bug?

I have a Motorola Milestone, and I remember in the past, at least the folder addition worked.

  • Is this still a problem for you? I have not seen this behavior on my Droid, although it does seem to take a bit of time to get fully synchronized. – ale Nov 6 '10 at 20:38
  • As a workaround, I deleted the account and registered it again, and it worked, but I'm not sure if this can be considered a "solution". – Willian Mitsuda Nov 6 '10 at 21:10
  • I think you should post that as an answer and mark it as the accepted answer. The Mail app is very buggy and basic and until it is improved I suspect there is no other solution. – Matthew Read Dec 26 '10 at 21:23
  • @Matthew agree, although I've started to try Touchdown as an alternative, I think it's fine for this specific question. – Willian Mitsuda Dec 29 '10 at 1:20

I know you were going for the "onboard" solution for Exchange e-mail, but at my workplace a bunch of folks use Touchdown:


Only problem is that is is $19.99. It works well with ActiveSync policies and doesn't force you to encrypt your whole device if your SysAdmin has required as such.

  • another problem with TouchDown is battery drain. I finally had to uninstall it because it was draining my battery several times faster than the stock email app. – Justin Grant Dec 23 '11 at 21:56

I ended up deleting my account and registering it again, and it worked, but this is a workaround.

As pointed out by other people, the native Mail app is buggy, so I started evaluating Touchdown.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.