I followed this guide until fastboot flash boot boot.img included and OK

Then reboot in recovery mode
Then "Now tap Factory Reset, then Format data / factory reset" included and OK

/!\ BUT since then, adb can't see my Nexus phone (Pixel 2XL - "taimen"), neither is it visible with lsusb when in recovery mode. I tried "Apply from ADB" or "Enable ADB" via lineageOS recovery mode gui, but adb devices returns an empty list :-|

When in fastboot mode, I can see the phone via lsusb :

[stan@stan-xps139305 ~]$ lsusb
Bus 003 Device 012: ID 18d1:4ee0 Google Inc. Nexus/Pixel Device (fastboot)

Is there a way to get my phone recognized by adb, or to flash it via fastboot directly... ?
Also can udev rules help... ?

N.B. : SECURE BOOT is ON (don't know if it can be blocking...)

[EDIT] >>>

I also tried several USB cables/ports already :-|
I'll try on another computer too ASAP

I just fear the phone USB mode is kinda stuck while in recovery mode.
This page shows the possible modes for pixel phone (mine is PIXEL 2 XL): https://devicehunt.com/view/type/usb/vendor/18D1
4ee2 instead of 4ee0 is what I expect, but hell no.
How is it that I can see the phone with lsusb while in fastboot mode, but cannot see it at all while in recovery ? <<<

[NEW EDIT] >>>
these are the udev rules I've set:

#GOogle Inc. 
SUBSYSTEM=="usb", ATTR{idVendor}=="18d1", ATTR{idProduct}=="4ee0", MODE="0666", GROUP="plugdev"
SUBSYSTEM=="usb", ATTR{idVendor}=="18d1", ATTR{idProduct}=="4ee1", MODE="0666", GROUP="plugdev"
SUBSYSTEM=="usb", ATTR{idVendor}=="18d1", ATTR{idProduct}=="4ee2", MODE="0666", GROUP="plugdev"
SUBSYSTEM=="usb", ATTR{idVendor}=="18d1", ATTR{idProduct}=="d001", MODE="0666", GROUP="plugdev"


  • If you enable adb or start side-loading mode (Apply from ADB) at least lsusb should show some device. May be the recovery has a bug, try an older version or try TWRP recovery for Pixel 2XL, for adb sideload it should not make a difference if you use TWRP or LineageOS.
    – Robert
    Nov 9, 2023 at 13:48
  • I cannot flash anything, seemt that the device is readonly now (as 4ee0 suggests...)
    – St3an
    Nov 9, 2023 at 14:00
  • ... I initially could flash a boot img but no more since then...
    – St3an
    Nov 9, 2023 at 14:06
  • instead of lineage bootloader I've been able to flash (with fastboot) twrp. It still cannot be seen through adb... Perhaps there is smthg to do with udev rrules ... ?
    – St3an
    Nov 12, 2023 at 16:47


You must log in to answer this question.

Browse other questions tagged .