2

Earlier today, I noticed something strange. Google Classroom isn't following the alphabetical arrangement of apps in my app drawer.

I swear this weird issue only appeared today, and I don't recall doing anything that might have caused it. I've tried different launchers and it's the same thing—either the app is at the beginning or at the end of the list of apps.

I installed a package manager app and I think I've figured out why this is happening. It appears that the app is getting installed with (a) space character(s) before the actual app name.

As to why this is happening, I have no idea. I've tried almost everything (uninstalling and reinstalling, installing a previous version of the app, etc.) bar a factory reset, but the issue persists. Can anyone help me out?

My phone is a Samsung Galaxy S23 running Android 14 (One UI 6).

5
  • 3
    The app name is by default stored in the (language specific) resources of the app. Most likely the space at the beginning is a bug for your language.
    – Robert
    Nov 13, 2023 at 13:31
  • 1
    Wow. I changed my language from English (United States) to English (Philippines) recently and never noticed the change in app order happening. I switched back to English (United States) and the problem is fixed. Thank you so much, @Robert. Now, to make a bug report to Samsung. Nov 13, 2023 at 13:45
  • As this solves the issue: does one of you two mind writing up an answer? :)
    – Izzy
    Nov 13, 2023 at 13:53
  • 1
    Why a bug report to Samsung? The app is from Google, therefore Google has defined the app name and your phone just displays the name as defined by the app. And a space is ASCII code 20 and therefore sorted before ASCII c code 67.
    – Robert
    Nov 13, 2023 at 13:59
  • I see. Thanks for the clarification. Can you copy your initial reply as an answer? Nov 13, 2023 at 14:34

1 Answer 1

0

Apparently, this is a bug with the system language of my phone. Setting it to English (United States) fixed the problem for me. Thanks to Robert for the solution.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .