After upgrading my Rogers Galaxy SII (I727R MODEL) to ICS. I cannot take screen captures of activities.

I've tried using home and power as with gingerbread as well as power and down volume together. Neither works.

Is there another way or has this feature been disabled by rogers?

Any help is appreciated.

2 Answers 2


Press and hold the volume down and the power button at the same time.
(Pressing the volume down slightly before the power and holding both..will not work)

Pressing them exactly at the same time and holding will work.


On my Xperia Play I have to hold Vol Down and Power for longer than I did on GB (it takes about a couple of seconds) before it will take the screenshot. Try the different combinations but hold them down for a couple of seconds.

  • I've tried it several ways. I either end up with the task manager opening or the volume control just turning down. I'm starting to thing Rogers just performed another bad update. After all it took them 6 months longer than most to finally release ICS.
    – Mike
    Commented Jul 7, 2012 at 1:15
  • 1
    Just figured it out. Still the home and power keys. It just won't work on home screen like before. You have to be in your browser, app, gallery etc. Thanks for the prompt reply :)
    – Mike
    Commented Jul 7, 2012 at 1:30
  • 2
    It's a bit stupid that it doesn't work on the home screen. I know it's not something you'd want to take a screen shot of a lot but still. Glad to see you got it sorted.
    – Darcon
    Commented Jul 7, 2012 at 1:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .