So, I was attempting to revert from Android 13 to Android 10. Unfortunately, I forgot to flash the Android 10 version of the Ofox recovery and instead flashed the custom ROM (Havoc) from the existing Ofox recovery that was already installed. Subsequently, it became stuck on the boot screen, and now, whenever I try to boot into recovery, it directly enters fastboot mode. This mode is not being detected by both Windows 10 and Linux.

Following that, I attempted to install drivers and tried everything I came across, but the device is not detected when it is in fastboot mode. I also tried different cables, but without success. Meanwhile, other Android devices are being detected in both Windows and Linux, but my Redmi Note 7 Pro isn't.

So is there any way i can get it to work or falsh recovery/rom. Please help me...

  • If you are on Linux does lsusb detect the phone (check output one time with phone attached and one time without and then compare)?
    – Robert
    Nov 18 at 12:06


You must log in to answer this question.

Browse other questions tagged .