I have this file:


Cannot delete. I get a <java.lang.illegalargument> response when I try to delete using several different file managers. My phone is unrooted. Tried through javascript, termux, iShredder, and others. Have tried to understand the black diamond with the question mark, but unclear what it truly is. Am a real novice, so have patience.

Any suggestions on how to delete this file.

  • 1
    Have you tried an alternative file manager like Solid Explorer, or a similar tool, to delete or rename the file?
    – acejavelin
    Commented Dec 6, 2023 at 0:12
  • 1
    Related/possible dupe: How to delete miscoded file in Android
    – Andrew T.
    Commented Dec 6, 2023 at 5:44
  • I did try several different file managers, not specifically Solid Explorer. I will try that. Thanks.
    – Jimmy B
    Commented Dec 6, 2023 at 15:00
  • Solid Explorer did not work. Cannot delete file. Thanks for the suggestion.
    – Jimmy B
    Commented Dec 6, 2023 at 15:07
  • As per related/possible dupe, I got the same result with Termux as in the question. Says file does not exist....but it's there.
    – Jimmy B
    Commented Dec 6, 2023 at 15:10

2 Answers 2


play with find until you get the single line with (1) result.

~ $ find -L /sdcard -mindepth 6 -type f -name 'brooke-shields*80.jpg' -print

add the -delete flag to delete result(s)

  • Rename the file and check if you can delete it. Also, have you tried the same with adb?
adb shell rm /storage/emulated/0/Tones/test1/test2/test3/test4/brooke-shields,-a�os-80.jpg
  • It won't let me change file name, I can't move it, I can't copy it, I can't delete it. Per iShredder, it's a "permanent file." Don't want to Factory Reset, but might be my only option. Have ordered a new phone, exactly the same as the one I have (other issues prompted that change), but am concerned that backed up files will contain same undeletable file. Tried several different file manager apps, was suggested to us Solid Explorer. Will try that. Thank you for responding.
    – Jimmy B
    Commented Dec 6, 2023 at 15:00
  • Solid Explorer did not work. Cannot delete.
    – Jimmy B
    Commented Dec 6, 2023 at 15:08
  • I have not tried that, nor do I have any experience with that, but it's worth a shot. Hopefully I'm smart enough to figure it out. Thanks for the suggestion. I'll let you know.
    – Jimmy B
    Commented Dec 6, 2023 at 16:34
  • adb seems to require the use of two (2) Android phones or a PC. I currently don't have access to either one. Not sure if I will be able to utilize adb.
    – Jimmy B
    Commented Dec 6, 2023 at 17:36
  • 1
    apps cannot access the app-specific directories that belong to other apps, therefore adb is recommended
    – alecxs
    Commented Dec 6, 2023 at 19:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .