7

I have a Motorla Droid running CM6 (essentially Android 2.2). I'm connecting to Windows 7 machines via USB. Every time I plug in my phone via USB it automatically mounts the SD card as external storage.

How can I stop this behavior? I haven't really noticed when it started, sometime after I installed CM6?

7

Apparently the Winamp app has an Enable auto-mount setting that is by default set to true. Problem resolved.

  • Also I found in the past that the DoubleTwist app annoyingly does this too. – GAThrawn Oct 31 '10 at 17:55
  • I believe in both cases the publishers of these apps consider this a helpful feature. – ale Nov 1 '10 at 12:34
  • 2
    I find it highly annoying because I usually just plug in my phone via usb to charge, not mount as a drive – Bryan Denny Nov 1 '10 at 12:52
  • Well, at least there is the option to turn it off. – ale Nov 1 '10 at 15:19
0

While connected via USB, you will notice a USB icon on notification bar.

Drag the notification bar down, you will see a "USB connection" item. Click it.

Select "none" or "nothing" (I'm not sure about the option name in english, because my Motorola Milestone is in portuguese).

  • Doesn't answer the question. His is auto-mounting, before he picks anything from the notification item. – davr Nov 3 '10 at 17:58
  • You only have to do this once. The next time you connect your phone via USB, it won't auto-mount. – Willian Mitsuda Nov 4 '10 at 3:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.