Been given a Desire HD that seems to have had a bad Radio Flash

I have spent perhaps 50 hours on this problem as follows:

Screen is always black whatever I do (unless /sbin/recovery - see below)

Power on: 3 Vibrates and Orange light (flashing) and in Windows Devices shows: Qualcomm CDMA Technologies MSM

Power on + Volume up: same as above

Power on + Volume Down: 5 vibrates and Green light and in Windows Devices shows: Qualcomm CDMA Technologies MSM

Connect device power lead and don't turn on:

One Vibrate Shows in Device Manager as Android USD Devices -> "My HTC" (installed OK) Also shows an "HTC DIAG" device with question mark (can install this with software from the web) F: drive comes up but cannot be accessed

can be seen in ADB devices as: HTCxxxxxxxxxxxxx RECOVERY

fastboot devices

NO fastboot... (not seen whatever I do)

adb shell

At this stage I cannot adb shell into the device as the "sh" is missing, so I adb push /system/bin and/system/lib over to the Desire HD (from another Droid) and can then adb shell to a root ('#') prompt.

I seem to be in a ramdisk, with no changes saved across reboots (not persistent) - but I do have write access to /dev/block/mmcblk0 partitions!!

NO SDcard mounted

The sd card is not mounted and seems not be recognized due to the faulty (radio?) flash.androidboot.cid is totally corrupt (crappy strange characters)

if the kernel boots why doesn't the screen come up???



msmfb_probe() installing 480 x 800 panel mdp_lcdc_probe: initialized (probably probing for the display???)

...some stuff....

err: Device config mismatch

is this where the screen fails?



Issuing reboot from adb root shell # and the phone vibrates continuously and green led flashes!!

My only hope of recovery it seems is:

1) Reflash all mmcblk partitions with stock from adb (but I don't have the images).

2) Somehow rebuild the bootloader so I can get some life on a reboot/power on.

3) Flash a radio.img via adb (I don't have any fastboot access). And perhaps this will 'repair'the device.

4) Make PD98IMG.ZIP (or whatever) persistent in storage to allow me to access it on an /sbin/recovery reboot (somehow get it into /data which at the moment isn't persistent across reboots).

5) "fastboot oem enableqxdm 0" somehow from adb (I don't have fastboot) so that an /sbin/recovery can retrieve the PD98IMG.ZIP from the sdcard and reinstall stock.

Any help appreciated. I really believe it can be done!

  • update, can mount /dev/block/mmcblk0p26 as /data after formatting as ext2.. so now have persistency across reboots!
    – nfc-uk
    Jul 9, 2012 at 10:48
  • Now pushed PD98.img to /data and /sbin/recovery --update_package=DATA:PD98.img and this kinda works! Fails with E:signature verification failed
    – nfc-uk
    Jul 9, 2012 at 11:07
  • Chat? PS: have you tried some of the patched hboot bootloaders? They should come with fastboot enabled. (I have only some experience with the original Desire here)
    – ce4
    Jul 9, 2012 at 11:50
  • I have tried to write some bootloaders directly to the emmc, mmcblock... but although it writes OK, I still boot to stock recovery 3e and even then can't seem to boot into a signed zip... am I even doing things correctly? Do you know where I should write hboot to? I believe my faulty radio is causing the boot issues! Sorry I mean PD98IMG.zip earlier....!
    – nfc-uk
    Jul 9, 2012 at 12:13
  • 1
    PS: the PD98IMG.zip only works if you are S-OFF already. Else you need to insmod a special kernel module and do it that way (see comment above).
    – ce4
    Jul 9, 2012 at 13:39

1 Answer 1


To add, after a little thought I think the lack of a cache directory may have been my problem all along. I formatted this ext2 and this may have solved the problem. Therefore a damaged cache directory might have been the root cause of this problem.

after formatting the cache and running /sbin/recovery it went straight into Clockwork (it was a big surprise) .. I went to HBOOT and RUU'ed a new ROM immediately (unfortunately in my excitement and due to a mislabel by the uploader) it turned out to be a Telus one... which is giving me problems.. but heck.. simple ones.

The moral here is don't give up. Nearly everybody said this was a bricked phone. But, I think, if you have HBOOT/fastboot or (most probably need rooted) ADB access you can do many things to get things going - I learned a lot ))))

  • And many thanks for your help C. It was much appreciated!
    – nfc-uk
    Jul 12, 2012 at 15:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .