I have been deliberately avoiding the latest Verizon D2G update for a few months now. It is really annoying that there is no way to make it stop asking me. But tonight I was tired and my finger slipped and it accidentally accepted instead of delaying 12 more hours. My phone started to shut down to install but I quickly pulled the battery out. Now every time the phone boots after about a minute of starting services it apparently remembers it was going to update so it starts shutting down the phone.

I have tried going to updates and manually looking for an update, in the hopes that this would confuse the phone and it would start asking me again if I wanted to update, but in the middle of searching for an update it just suddenly aborted and threw me back to the setting menu, and subsequent attempts just immediately aborted. [edit:I tried this again, this time immediately looking for updates as soon as I could login. This time it immediately started searching, and continued searching until the auto-shutdown started.] I also tried looking at the processes with a system monitoring app I have but wasn't able to identify a process to kill before it started shutting down - and even if I did I am afraid it might still start updating when I'm not watching later.

Is there any way I can abort the install? I am afraid to let it actually start installing because I don't know what to expect. Does it offer me a chance to cancel? If not, I fear I might brick my phone if I pull the battery after it starts to update.

And in case you are wondering, I absolutely will not allow this update because of the risk of the update breaking some obscure feature I depend on. For another, this is the update that removes the ability to root. My phone is not rooted, and I really don't have the the time or inclination to root it at the moment (it is another risk I don't want to take) but I won't accept the ability to be removed.

Edit: The following information is from the adb log:

07-XX XX:31:15.883  1306  1433 I ActivityManager: Start proc com.motorola.Upgrader for broadcast com.motorola.Upgrader/.UpgraderReceiver: pid=2334 uid=1000 gids={3002, 3001, 3003, 1015, 2001, 1007}^M
07-Xx XX:31:15.953  2334  2334 W UpgraderReceiver: !!! INSTALL UPDATE !!!^M
07-XX XX:31:15.961  2334  2334 W RecoverySystem: !!! REBOOTING TO INSTALL /cache/Blur_Version.4.5.608.A956.Verizon.en.US.zip !!!^M
07-Xx XX:31:15.961  2334  2334 I RecoverySystem: in google bootCommand, 23103 disalbed^M
07-XX XX:31:15.961  1306  1340 D ShutdownThread: Notifying thread to start radio shutdown^M

So, it wants to install 4.5.608.A956.Verizon. [update: actually, that can't be right, because that is the version I am already running! ]

Also, the following did not work:

bash-4.1$ ./adb uninstall com.motorola.Upgrader

bash-4.1$ ./adb shell kill $(./adb shell ps | grep com.motorola.Upgrader | awk '{ print $2 }')
could not kill pid 2379: Operation not permitted

Update: Well, I am thinking it is looking like maybe the only way to avoid the update is to actually root my phone. :-(

  • Hmm, the update wound up in /cache? Tricky. If it was on the SD card, I'd say delete the downloaded ZIP. If you were rooted, I'd say the same thing. Have you poked around in the recovery on the phone to see if you can wipe /cache from there?
    – dgw
    Commented Jul 9, 2012 at 8:15
  • try 'adb shell' and the 'pm' executable (package manager). It has a 'clear <PACKAGE>' and 'disable <PACKAGE>' command and others that might be useful for your problem.
    – ce4
    Commented Jul 9, 2012 at 11:14
  • Actually, there is a way to stop it asking, an app called Fota Kill. Too late now, maybe -- but if you get the update removed, it might still be interesting for you.
    – Izzy
    Commented Jul 9, 2012 at 11:45
  • @ce4 looks like clearing and disabling the package also requires root, its giving me permission denied.
    – Michael
    Commented Jul 9, 2012 at 15:39
  • Can you not reboot into recovery? and mount the /cache partition and delete the zip from there.
    – t0mm13b
    Commented Jul 9, 2012 at 16:09

1 Answer 1


Ok, here is how I solved the problem:

I followed the first part of the directions here: http://oldwiki.cyanogenmod.org/wiki/Motorola_Droid_2_Global:_Full_Update_Guide to wipe the flash and install older version of the Motorola software. (specifically, section 2.1.1) Then I upgraded to the version that I was running before the update started attempting to run.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .