My Galaxy Tab P1000 was charging when it fell down.

I tried plugging it in again to continue charging but the battery icon now appears with a cross mark and instead the MTP mode initializes. How can I get the Galaxy Tab to charge normally again?

  • 3
    It's possible the fall caused damage to the tablet's internals, and that damage is preventing charging. If a reboot doesn't resolve this problem, your options might be limited to getting a replacement unit, or taking this one to be repaired.
    – Chahk
    Jul 9, 2012 at 12:58
  • 1
    It's most probable that some pins of the micro-usb port in your phone have been disconnected from board due to falling down, so the phone does not receive charge, and it detects connection to PC instead of charger. Get your device repaired by official samsung service.
    – yrajabi
    Sep 22, 2012 at 19:14

5 Answers 5


Alright guys, I had the same problem as you are experiencing. When I plugged my tablet to the wall charger it just showed a lightning icon crossed with a red cross, it wrote mtp connected and did not charge. I have read some forums about this problem there are only a few of them. I have decided to reset to the factory settings, since I was desperate at this point, I did not even hope. Then i solved my problem just by checking the connection between the box u put in the wall plug and the cable. Honestly I wanted to throw it away but luckily i did not, it works fine now.

Hope this could help you or even if it does not I just wish you good luck with solving it.


I just blew into both the port on my tab for charging, and the port on the cable. Now, it charges normally again! Go figure!

  • Perhaps dust! :)
    – Zuul
    Oct 23, 2012 at 11:42
  • Sometimes the simplest solution is the best. Oh how i wish i could blow the dust out of some SNES games again... Oct 23, 2012 at 14:49

Most of the time this problem is being caused by dust, dirt, grime, or some other type of contamination coating one of the usb pins on the inside of the usb port. Easiest fix is to blow some compressed air into the usb port repeatedly until the dust/dirt is blow clear. You can also use "Contact/Control Cleaner & Lubricant" available from Radio Shack. Remove the phone battery and hold the phone upside down while using the compressed air or cleaner/lubricant to blast the usb port clean. Wipe off any residue then re-install the battery. Power up your phone and it will now function properly.


The behavior you are seeing is consistent with plugging the tablet's USB cable into a standard USB port.

If you plug the tablet into the "official" power adapter, you should see neither the red "X" on the battery icon, nor the MTP scanning update.

The tablet will only reliably charge (and thus no red "X") when plugged into the special wall adapter, because the adapter is modified to deliver a higher current output than a computer's USB hub or a generic USB power adapter will deliver. When the tablet detects that it is on a standard USB connection it displays the red "X" on the battery icon as the tablet may not gain battery charge as fast as it uses it (the tablet's screen and network connections together can drain more than a standard USB connection can supply).

The MTP scanner is the media scanner that runs when the tablet thinks it might be plugged into a computer. I believe this is so it can quickly copy media off to your desktop, but I'm not sure on the details. Basically, its another symptom of using a vanilla USB port.

See this question for more details: How much power does a Galaxy Tab 10.1 charger need to supply?


I had the same problem until I tried one method by accident.

  1. Connect the tab with the relevant port.
  2. Now slowly connect the USB side of the connector to the USB port in your computer (remember to be slow enough till 50 percent of the connector is pushed in).
  3. Your tablet will now start charging normally using the PC.
  4. Now you can push in the remaining half of the connector into the slot.
  • This seemed like the strangest solution but guess what...IT WORKED FOR ME!!! Wish I could give you more than one point!
    – Gene S
    Dec 19, 2013 at 3:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .