My Redmi Y2 phone was working fine for long time but suddenly I found that "VOLUME UP" key is not working so I tried to restart the phone but it got stuck into Recovery 3.0 screen. It only gives 3 options:

  • Reboot
  • Wipe Data
  • Connect with MIAssistant

Pressing on "Reboot" displays two option:

  • Reboot to System
  • Go back to Main Menu

Pressing "Reboot to System" reboots device and again goes back to "Recovery 3.0" screen, this keeps going on. I don't want to loss data so I didn't try "Wipe Data" option. Its not moving out of this screen no matter how may times I reboot it. I tried FAST BOOT by pressing (VOLUME DOWN + POWER) button, but it has no effect, it shows logo for a moment and ended up to same "Recovery 3.0" screen.

enter image description here

  • Is your device rooted and did you install A Magisk module? This happened to me once when the recently installed module misbehaved//I got out of it by booting into safe mode and disabling that module//Whether this is the case for you or not try booting into safe mode and boot into normal mode from there. Google for instructions to boot into safe mode for your device
    – beeshyams
    Commented Dec 15, 2023 at 8:25

1 Answer 1


Volume Up button is for recovery mode. Repair the button.

  • thanks, this worked for me after fixing the button. I tried to lift the volume button a little and then reboot the phone by pressing "VOLUME DOWN + POWER" button. It goes to FASTBOOT (took some time to come out of this) and then started normally.
    – ramya
    Commented Dec 29, 2023 at 7:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .