I see a few related questions but I still ask this question (android.stackexchange.com#246629 mentions the same error although the situation is not exactly the same with mine).


On Play Store I see this message and doesn't seem to be able to set up Family Library.

Country not supported
Confirm the country associated with your account

Operation to reproduce the issue

On Play Store, choose Setting -> Family -> Sign up for Family Library -> SIGN UP then move on choosing yes or equivalent.

Things attempted but didn't seem to take effect

  • VPN (nordvpn) to a US location before doing what's in operation section above.


  • All of my payment methods are in a country A. I'm seeing this issue in country B where I came for a week-long vacation.
    • Country A: the US, B: Canada
    • I've never tried the operation in my home country A UPDATE 2024/01/03: Now I'm back to my home country and tried the same operation but still seeing the same issue. VPN disabled.
  • I tried from both of the following:
    • Android
    • ChromeOS 119.0.6045.212 (Official Build) (64-bit)
  • When back in US, did you disable your VPN? Jan 4 at 5:12
  • @Rohit Gupta Yes, as I updated my post, VPN was no longer used for awhile.
    – IsaacS
    Jan 4 at 16:40

2 Answers 2

Country not supported
Confirm the country associated with your account

Please ensure you set your home country in your google account. Your home country is the country where you live permanently and where your official government and banking documents are sent to. When you publish apps, answers to the questions asked by the google app store wizard will set the regulations your apps will be subjected to. That's the reason the app store is giving you a hard time and will continue until you match your home country (the one you set when you created your google account originally). Your IP locale does not apply here since you mentioned that you're back home and are no longer using your VPN.

  • Thanks for comment. In my case though, my Google account's country was already set to my primary country.
    – IsaacS
    Jan 8 at 22:57
  • @IssacS anytime. I understand.
    – Full Array
    Jan 9 at 4:21

Not exactly sure what was a fix, but today after the following things are done, signing up "Family Library" finally went through. Not I'm back to my home country for 4 days by today.

  1. Made sure VPN was off. Btw today I used Ubuntu Linux while I used ChromeOS for my OP. Hope this OS difference is irrelevant.
  2. On another Google account of mine, I found a "Family Group" was set up with someone (my siblings) who might be based on yet another country (say country C). I removed them from this "Family Group", which I don't recall we've ever used.
  3. On the Google account in question, on Chrome web browser I went to "Family Sharing" setup page (myaccount.google.com) -> In "Other products and subscriptions you can share" choose "Google Play Family Library". Then follow signing up process -> Success.

So, sorry as I don't have definitive solution but hope this helps others who run into the same issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .