2
  • Pixel 6 Pro
  • Android 14
  • 256Gb storage

About a week ago my phone began complaining about a lack of storage - there was only about 2Gb left! I've done a bit of a tidy up and freed another 4Gb but yesterday I realised the System is taking up 224Gb!!

I've spent the last 24 hours googling and searching on YT and on here but without rooting it I can't see any way to clean up this storage (which appears to be at least 100Gb more than it should be) or even see what's happening.

I'd rather not do a factory reset but that's what I'm facing if I can't find a solution here!

0

1 Answer 1

2

Since it's the /system partition gobbling up huge space, I doubt if there is anything that can be done by the user (even on a rooted device, since the partition is "read only"), except:

Caveat: I haven't tried the options below on my Pixel 4a/6a

  1. Flashing the stock ROM again without the -w before running the flash-all script to prevent data wipe.

  2. Flashing factory image flashing in fastboot with force option on (see this guide for both options 2 and 3).

IMO it's best to jump to option 3 with force option enabled (without wiping data), since this involves dynamic partition sizing glitch. The force option apparently fixes dynamic partition sizing based on what the developer of PixelFlasher, a GUI tool for flashing / updating / rooting / managing Pixel phones says here:

Full OTA is indeed full ROM, but based on observation, when it comes to switching firmware, or even downgrading, it does not work, I suspect that it does not do partition resizing. I do quite a bit of messing up on my test phone and often I had to resort to factory image flashing in fastboot with force option on.

(Emphasis supplied)

I wanted to put all this in comments since I haven't tried these options but it was getting to be too long, so made an answer of it, more as a pointer towards possibilities then a definitive course of action.

4
  • 1
    I did a factory reset - system is now less than 20gb(!) and the backup restored most of my apps so a result in the end!
    – deep64blue
    Commented Dec 28, 2023 at 20:20
  • 1
    Good that's fixed. Just in case it was due to malware, and happens again (hope not), you may have to try option 3 ( see first para of answer
    – beeshyams
    Commented Dec 29, 2023 at 11:05
  • Sadly it has happened again so am now trying option 3.
    – deep64blue
    Commented Dec 30, 2023 at 9:45
  • 1
    Sorry to hear that, all the best. It may/not be malware, it could be partition sizes glitch as quoted in the answer
    – beeshyams
    Commented Dec 30, 2023 at 11:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .