0

I have a Samsung Galaxy S22 Ultra, so it is not even two years old. When my Wi-Fi is on, so is my mobile data, and the data works on and off. If I turn off the Wi-Fi off, I lose mobile data. I have not been able to make/receive calls/texts for about a week now.

I literally have done everything. Factory reset, Samsung remote diagnostic, Asurion diagnostic, changed carriers, went from SIM (because it wasn't working no matter the carrier) to eSIM (doesn't seem to work either).

Does anyone know what the issue is?

5
  • 2
    Did you mean you cannot toggle mobile data on if Wi-Fi is off? I read "does not work" as if the device consuming mobile data even when Wi-Fi is on, which in most Android, it shouldn't work that way; Wi-Fi is always preferred for internet connection if connected. However, you also mentioned "calls & texts", which I don't think is related to mobile data, but more an issue of carrier telephony, so I'm honestly clueless...
    – Andrew T.
    Commented Jan 3 at 17:02
  • I meant to say my mobile data turns off when my wi-fi is off. Sorry, I am new to this. I cannot make calls or receive them. I also cannot send or receive texts. When my wi-fi is on I have bars, but when I turn my wi-fi off the bars go away and I have no service. Commented Jan 3 at 17:54
  • Does another mobile in the same location have bars? It could be that you have no mobile reception where you are. Is Wifi calling On? Try posting screenshots of your Settings -> Connections and its sub menus. I have Note 20 Ultra and everything works fine. Commented Jan 4 at 3:45
  • I can tell you from personal experience that when my S22u1 did this I tried for a month to track it down before sending to Samsung for RMA and they found micro-cracks in the sandwich (multilayered PCB main and daughter board, or the Logic board if you will). Sorry, but I wish I had better news for you.
    – here_miah
    Commented Jan 5 at 2:40
  • Yes, all of my other devices are good and on the same Wi-Fi. I am going to have to get a new phone. Thanks everyone for your responses. Commented Jan 5 at 4:58

0

You must log in to answer this question.

Browse other questions tagged .