I have a Galaxy Tab s2 that constantly boot loops.

It is a similar situation to this question which has no answers.

Power: The device enters a boot loop when turned on.
Power + Vol up + Home: says "booting recovery" in top left, samsung logo appears. After a couple min the screen goes blank and it enters the boot loop again.
Power + Vol down + Home: enters download mode which looks like this:
enter image description here

First thing I did was download and attempt to flash TWRP recovery, but it said FRP lock, so I can only flash stock firmwares.

I downloaded the stock version for this device (guessing the region code because I don't see it in download mode).

I used odin4 for this, and it completed successfully. The system update page came up, and at 32% said 'erasing' and restarted the device. See Here.

The suggestions said to
Reboot into recovery volume up+home+power
Wipe cache/factory reset

However, when I attempt to reboot into recovery, it just shows the samsung logo and then goes back to a boot loop. So there's no way to do the factory reset.

I've looked at the odin options, and it has -e which is erase, which I have tried to no effect.

I have also tried heimdall but that runs into this issue so I would need to build heimdall from source so I'm not sure it's worth it.

I don't want to continue debugging this if it's a hardware issue (the ROM is damaged/corrupted or something). Is there any other option I can try?

Also, it's possible the region code is incorrect, but I have no way to know since it's not showing up in the download mode. South Africa only has 2 codes, XFA and XFV. I tried both, XFA doesn't even get to the install screen, XFV gets much further so I figured that was the right one. If this is an internationally sourced device then I'm screwed.


You must log in to answer this question.

Browse other questions tagged .