I have a rooted (Magisk) Fairphone 5 running the Fairphone ROM. I installed F-Droid using adb. I cannot update F-Droid itself from with in F-Droid. From F-Droid I have tried to install OI File Manager, LinPhone, and Easter Eggs. They do not install and the only feedback I get is "package installer keeps stopping". I also downloaded the OI File Manager apk from the github site directly to my phone and tried to install it from AOSP file manager with the same results. I am allowing installing APKs from unknown sources in settings. I am able to install apks using adb.

I ran adb logcat when trying to install OI File Manager and found two possible errors:

NotificationService: Cannot find enqueued record for key: 0|org.fdroid.fdroid|1|https://f-droid.org/repo/org.openintents.filemanager_40.apk|10195
PackageParser: Unknown element under <manifest>: meta-data at /data/user/0/org.fdroid.fdroid/cache/apks/f-droid.org--1/org.openintents.filemanager_40.apk Binary XML file line #63

I have also installed SAI which gives more detailed error messages and it says "Can't install packages while in secure FRP"

But since it is happening with different APKs, I am not sure how to proceed to fix this.

  • I know that this issue stems from the triggering of FRP at some point in the rooting or setup process. So the solution is to solve that problem so I have posted a new question to that end. Commented Jan 25 at 22:15

1 Answer 1


As mentioned in my comment, this problem is a system level problem, not a problem with F-droid, the package installer or any individual APK file. I have solved it using

adb shell settings put secure secure_frp_mode 0

and this solution persists across restarts, at least in my rooted context.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .