0

I have a tablet running Android 2.1, and I really want to have the S Memo app on it. However, all the APKs of S Memo from the web are for Android 4.0 and above. But, S Memo was originally designed for Android 2.3. So, how can I port it from Android 4.0 to Android 2.1?

The S Memo app is a simple memo app in which you can draw or write stuff, so I don't think it would need any Android 4.0 stuff. What do I do?

5
  • 1
    Google introduced in Android 3 & 4 a large set of new APIs that make app development easier. Would be surprised if S Memo wouldn't make use of it. So apps usually differ a lot between Android 2.3 (API 10) and Android 4 (API 14). You are simply 10 years too late as Android 4 has been released 13 years ago. The download sites have already purged apps for pre Android 4 versions to save disk space as there is next to no demand for such old apps.
    – Robert
    Feb 11 at 16:11
  • But I want the S Memo app on my Tablet.....and there is no memo app online for android 2.1.
    – eee zzz
    Feb 11 at 18:18
  • However I can try to find the original S Memo app files from the Samsung Galaxy Note, that runs android 2.3. Now the problem is that I don't have an Samsung Galaxy Note, but there is also no archive with the Galaxy Note system files.
    – eee zzz
    Feb 11 at 18:21
  • 1
    Are you sure that S Note is running on non Samsung devices at all? Samsung always modified Android with own services and extensions and if an app uses them it can not work on devices that don't have the same services.
    – Robert
    Feb 11 at 19:48
  • 2
    Assuming that S Memo used Samsung specific APIs, if you can prioritize the features your want out of a note taking app,you can draw or write stuff asking on our sister site: softwarerecs.stackexchange.com for an Android 2.1 compatible Android app may be appropriate. There may be open source apps which fit your needs. Feb 12 at 2:31

0

You must log in to answer this question.

Browse other questions tagged .