0

I want to root my vivo Y33s. Here's what I tried: Unlock the bootloader (all commands like fastboot oem unlock are not recognisable) with fastboot boot directly from .img file:

downloading 'boot.img'...
OKAY [  3.494s]
booting...
FAILED (remote: unknown command)

How else I can root with Magisk?

3
  • 1
    Your phone seems to have a Mediathek CPU/SoC. Mediathek devices have a fastboot mode but it does not provide common functionality. There are special Windows based flashing tools available for MediaTek based devices.
    – Robert
    Feb 22 at 18:41
  • try this binary How can I unlock/root the Vivo Z1?
    – alecxs
    Feb 22 at 20:55
  • tried all this vivo fastboot etc
    – mkh34
    Feb 25 at 17:32

1 Answer 1

-1

Well, rooting a phone means wiping all data, but I guess you already backed up all data. Anyways, according to Rootmeguide, first up you need to unlock the Bootloader on the phone. You might have did that, but I wrote it in case you didn't. After that, you need to patch an boot image file using Magisk. After that, rename majisk_patched..img to boot.img. After copying the boot image file to a PC, you need to flash it.You need to open the "ADB" folder, and type "cmd" in the adress bar.The connect the phone, and type "fastboot devices" in the prompt, and hit enter. After that, type "adb reboot bootloader". That command will boot the phone into the fastboot mode. Then, depending on your partition system, you need to type another command. For an A/B partition system, you need to type "fastboot flash boot boot.img" For Non-A/B partition system, you need to type "fastboot flash boot_a patched_boot.img" and "fastboot flash boot_b patched_boot.img". Then, type "fastboot reboot", which reboots your phone, and then you have succesfully rooted your phone!

4
  • 2
    Hi. Did you use an LLM to assist in writing this answer post? Please see our policy on that here: meta.stackexchange.com/help/ai-policy.
    – Firelord
    Feb 24 at 7:46
  • Bootloader isnt unblocked, so i cant flash it
    – mkh34
    Feb 25 at 17:31
  • Sorry, now I saw your Comment. To unlock the bootloader,according to GetDroidTips. you need to type the command "fastboot bbk Vivo_bsp unlock_Vivo".
    – eee zzz
    Feb 26 at 18:15
  • and i said this also, none of commands like vivo_unlock, vivo_fastboot, bbk unlock not working
    – mkh34
    Feb 26 at 18:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .