1

I have a Nokia G42 5G with Android 13.

A week ago, a notification popped up, asking me to download the latest update (and also that that update was a week behind). Since the size was 2.67 GB, I decided to close the notification at the time; I would install it later. A quick search afterwards revealed that it was an upgrade to Android 14.

When I went to download it later (from SettingsSystemSystem update, then Check for update), it keeps showing “Your system is up to date”. This is how it has been since.

Now, I know that that is not the case because

  • there was that notification,
  • someone I know uses this very device (model) and they have already upgraded (means, it has been released in our location/market), and
  • one could check from Nokia’s Website that that update has been released.

My question is: how can I get that update?

I have installed Google Play system updates and what not. I have also cleared the ‘System cache’ app (don’t know what this app does) from SettingsMemory. I have tried using both WiFi and 5G data while the device was charged to full.

Screen-shot of ‘System cache’ app in ‘Memory’ in ‘Settings’

What else can I do? May be allow unrestricted data access to some app? May be clear some cache to force fetch that update? I won’t flash a custom ROM but I am willing to reboot to safe mode or connect to a computer to clear some hidden cache or run some code.

Technically, it seems to be possible to postpone updates; the system will fetch them later. Is it possible to reset that waiting period instead of waiting it out? (If that has been the case; my device is my own, not managed.)


On a related note: I recently had a run-in while installing the 2024-02 Cumulative Update for Windows 11 Version 23H2 for x64-based Systems (KB5034765) update on Windows 11. It downloaded, started installing, computer restarted, it installed all the way to 100%, and then rolled back with a “Something didn't go as planned” message. This happened quite a few times. I tried all kinds of solutions from all around. At the end, it turned out that all I had to do was rename/remove the C:\$WinREAgent folder. And it worked in a snap!

So, I know that software work in mysterious ways!

2
  • 1
    Ho often have you pressend the "Check for Update" button? To my experience in most cases the button does not trigger a check but shows the last result. Therefore press it a dozen times to be sure it has really performed an online check for system updates. Alternatively Nokia may have recalled the update because too many severe errors. Third possibility is that the update has not been released to all users. Releasing updates only to a certain percent of users is common practice to not getting overwhelmed by support requests in case something goes wrong.
    – Robert
    Feb 25 at 16:27
  • I have been restarting and pressing ‘Check for update’ several times a day since last week! If they have recalled the update, there would be news around. I don’t think that has been the case. Let’s see.
    – a_das
    Feb 25 at 17:27

2 Answers 2

0

At least in NZ, the updates are rolled out to groups of users at a time, presumably to avoid a bandwidth crunch.

  1. Repower your phone, if you haven't already.
  2. Wait at least a few weeks and then contact your provider, if you still havent seen it.
2
  • Yeah, the last option would be to wait!
    – a_das
    Feb 25 at 20:09
  • I deliberately put in the Windows bit, as anecdotal "evidence": that sometimes there are work-arounds. :-) Let's see if someone comes up with something like that.
    – a_das
    Feb 25 at 20:12
0

If you have notification logs enabled, you might be able to select the original notification for the update again. The option to select previous notifications was only added in more recent versions of Android.

2
  • I'm curious whether this may work, or if it does work, on which device models or Android versions. Selecting a notification on Pixel 3a, Android 12 only opens the Android notification settings, not opening its intent.
    – Andrew T.
    Feb 28 at 16:09
  • I'm not sure if the option existed before Android 13. It may also depend on the type of notification and how old it is. I've had varying success, but I know it does work more reliably than the old method of adding a setting widget.
    – Kovaelin
    Feb 29 at 5:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .