0

My Samsung Galaxy A24 phone used to work fine with my Windows 10 laptop via scrcpy.exe, on a USB-C cable. I did not change anything in the setup. Suddenly, now scrcpy shows the phone's screen fine on the laptop's screen, but mouse clicks have no effect, both left-click and right-click. How do I fix this? What I have tried is:

  • Restart the phone;
  • Pull out the USB cable cable and connect again.
  • Revoke USB debugging permissions;
  • Turn off and then on USB debugging. To no avail.

Still, mouse clicks do nothing, whereas the phone's screen is shown fine, and directly touching the phone's own screen with the finger works as expected.

3
  • 2
    What is the full output in the console? Do you use the latest version of scrcpy? (there are regular updates to adapt to Android changes)
    – rom1v
    Mar 5 at 8:03
  • 1
    check Developer options for "USB debugging (Security settings) Allow granting permissions and simulating input via USB debugging"
    – alecxs
    Mar 5 at 10:42
  • @rom1v Your comment solved the problem. I converted it in the answer. Apr 2 at 6:13

1 Answer 1

0

Somebody (@rom1v) here in a comment suggested to upgrade scrcpy to the latest version: just download the latest version. I just googled for scrcpy latest version. Magically, the new version worked OK.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .