I Have a Verizon Galaxy Nexus which was rooted. I used an OTA Rootkeeper to keep the root after I upgraded to 4.0.4 which worked great, I was able to use root well after the OTA update. But recently the root has stopped working however the apps that I had saved permission before the mysterious removal of root still work. So I can use Sixaxis, Wifi Tether, File Explorer with root permissions, etc. They all work great however any new app I download is unable to get root access. I first noticed it trying to flash a rom.

When I go into SU app says I have a outdated binary and when I try to update it (from 3.0.3) it fails to gain root access.

Any ideas why I've lost root access and how I can get it back short of going back through the entire root process?

  • What exactly do you mean when you say "root has stopped working"? Are there any error messages?
    – Chahk
    Jul 11 '12 at 15:48
  • No error messages. As I said in the post I had root on my phone that worked fine but recently something has changed which has caused it to break i.e. new apps I can install can't gain root access. But apps that previously had root permission still work.
    – Nick
    Jul 11 '12 at 15:53
  • Looks like problem with su program rather than root.
    – roxan
    Jul 11 '12 at 15:54

Having "root" just means you have a working su binary installed (the "su" application is generally just a management front-end for the linux-level binary installed in /system/bin or /system/xbin). So, something has gone wrong with the binary, or the way its installed, or its permissions, or its location, or ...

I suspect the apps that still work must have chown'd themselves once at setup time? So they only need su to work once, and after that they're good to go.

If you can connect an adb shell or run an Android Terminal (that was just the first play store search hit, I'm not endorsing that specific terminal), type "su" and see if you get a meaningful error. You can use adb to copy a new su binary over, or just re-"root" the device. See the FAQ questions here: http://androidsu.com/superuser/faq/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.