0

I've been using ADB from the command prompt on this Microsoft Surface Book 3 laptop with success for about a year. It upgraded to Windows 11 23H2 from 22H2 a couple of weeks ago, and since then, ADB can't see any devices. I've rebooted laptop and devices, tried two different cables, and updated ADB. I now have:

> adb --version
Android Debug Bridge version 1.0.41
Version 35.0.1-11580240
Installed as C:\android\platform-tools\adb.exe
Running on Windows 10.0.22631 

> adb devices
List of devices attached

It does not sound a tone when an Android device is connected, which it used to do.

I'd never needed to install special USB drivers on Windows 10 or 11, so I have not tried that. The devices do not show up in Windows Explorer. What am I missing?

1 Answer 1

0

As soon as I post the question, I think of something else to try, and start finding the solution.

The laptop had lost the ability to access ADB devices on its USB-A ports. It could do that via its sole USB-C port, and sounds a tone when an Android device is connected there. That's specific enough to report as a bug.

I don't usually use the USB-C port because it is too close to the power connector, making it awkward to have power and USB-C connected at the same time.

Then the laptop started ignoring its keyboard. This model is actually a 2-in-1, a large Windows tablet with an attachable keyboard, which bears the USB ports, power connector and so on. Detaching and re-attaching the keyboard got it working, and now the USB-A ports can see Android devices. Computers!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .