2

I can not disable my Google Play services because my old Samsung J7 (SM-J700H) phone does not let me disable the administrator privileges of Google Play services.

I am trying to do this because my phone has been giving me a repeated error since yesterday that

Unfotunately, Google Play services have stopped working.

I thought that if I uninstalled this, it might do the job. But whenever I try to disable/uninstall it, it says it has administrator privileges. The privileges it has is the "Find my Device" option turned on. When I try to turn that off, Settings stop working too, so I am pretty much boxed here.

Here are the fixes I have tried.

  • I deleted the cache of the Google Play Store.
  • I deleted all the cache partitions of the phone.

These fixes did not do the job and I am here for any kind of help.

2
  • 1
    Google Play Services are a core component of Google Android phones. Without it all Google apps and a lot of third party apps won't run. Instead of disabling it you should better clear it's app data (not only cache) and try to update it by installing a newer version manually.
    – Robert
    Commented Apr 21 at 20:38
  • Tried it but when try to clear data that message pops up again and goes back to settings Commented Apr 23 at 6:55

1 Answer 1

0

You need to clear cache and clear data for all Google Play and Google Play Services apps that you find in the Settings>Apps.

Then restart your phone.

1
  • When i try to clear data the message pops up again and it goes back to settings Commented Apr 23 at 6:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .