2

For the past few days, both for incoming and outgoing calls, the call app shows nothing but a full black screen, so I can't hang the call, push numbers, mute call, turn on speaker, etc. But the calls can be heard perfectly, it's just the interface

In the past few months I noticed that the phone takes longer and longer to show the caller ID, at first it was instant, lately it would take like 4 seconds between the moment it starts ringing and vibrating and the moment it shows who is calling on the screen. I don't know if this is related.

Things I've tried

  • Reboot the phone
  • Wipe apps cache/temp files
  • Reboot with Power+VolumeUp buttons pressed and then Wipe Cache Partition
  • Free up some space on the phone
  • Checked phone settings
  • Checked the proximity sensor: it shows 5cm, and when I cover it with my hand it shows 0cm, so this doesn't seem to be the problem. I don't use any covers for the phone
  • It's just the "phone call app", because if I tap on the home button the screen works as usual and I can use any other app even during the call

It's a Huawei P Smart (Android 9)

Do you have any ideas of something else that I could try or check? Thanks

3
  • 1
    Maybe a bug with a recent update of phone app? Uninstall all updates of the phone app and check
    – beeshyams
    Commented Apr 23 at 5:50
  • Thanks, no because the phone hasn't received updates for years
    – golimar
    Commented Apr 23 at 6:17
  • 1
    OK.. Please check if the problem occurs in safe mode(Google how to for your device) //If it doesn't, it means an installed app is causing it, if It does maybe you can consider factory-reset after backing up your data (drastic measure that may/not help)
    – beeshyams
    Commented Apr 23 at 7:14

5 Answers 5

5

I had the very same issue on my P20 Lite. After searching through the internet, I found this video, and following the steps shown there did actually solve my problem. Now the Phone app works without any issues, same as before it broke.

As shown in the video, you have to clear the stored data from the following two apps:

  • (Google) Maps (com.google.android.apps.maps)
    1. Go to Settings / Apps / Apps
    2. Search for "Maps" and select it
    3. Click on "Storage" and then press the "Clear Data" button
    4. Select "Delete" on the popup window
  • Google Play services
    1. Go to Settings / Apps / Apps
    2. Search for "Google Play services" and select it
    3. Click on "Storage" and then press the "Manage Storage" (in my case, "Manage Space") button
    4. Press the "Clear All Data" button and select "Delete" on the popup window

Disclaimer: these steps seem random, and I have no idea whatsoever why it works and what is the connection between these apps and the Phone app. However, its validity seems to be verified both by the linked video's comment section and this Reddit thread.

5
  • I had the same problem with my Huawei p10 lite. After researching a lot i found this video: youtu.be/_PIJkFwq414 But watch out your google account will be disconected after the last step. Probably there will be some other thigs that will be deleted but until now i recogniced only the google account
    – To08bi
    Commented Apr 28 at 11:53
  • I can confirm the above post and video fixed it for me. Thanks you so much I can now cancel the new phone I had on order. youtube.com/watch?v=_PIJkFwq414 Commented Apr 29 at 11:16
  • I followed the map and google play steps and it worked! I'm a long time IT professional and this is the most random fix I have ever come across in 40 years!!! Commented May 17 at 17:18
  • Same issue with Huawei P10 lite and the fix worked
    – Bogdan
    Commented May 28 at 19:06
  • I had same issue, it worked after cleaning the storage and cache of gmaps and play services
    – Mert Aksoy
    Commented Jun 1 at 13:21
2

I work in a mobile shop/service. In the last 1 month, I have come across 7-8 such phones that produce the same thing, and all of them were such "older" Huawei. They were all different years and models (Y5, P10 Lite, P10, P20 Lite, etc.) I tried to flash the factory ROM on some phones but it didn't fix the problem. As far as I have experienced so far, there is no solution for this.

2
  • It's really weird that factory reset didn't work. Could that mean that something has changed in the mobile network call system?
    – golimar
    Commented Apr 24 at 10:57
  • 1
    I have no idea what happened, but yea' its really bizarre thing. Btw i am living in hungary and it happened with all of our carriers we have. (Telekom, Yettel, Vodafone) Commented Apr 25 at 7:02
1

I installed an alternative phone call app and the new one works totally fine (I had to allow it to set itself as the default phone call app)

1

P10: Had the same problem & managed to fix it.

Go to Settings > App & Notifications > Huawei Home > Permissions > App permissions (all must be ON, e.g. Calendar, Contacts, Phone, etc.) > Additional Permissions > Dial through Contact (must be ON).

That did it for me.

1

Like golimar, I installed another dialler app and this cured the problem. It also shows that the proximity sensor is working, so that is not the problem. The problem seems to be an update to the Huawei dialler app.

I had previously tried resetting the phone; this cured the problem but only for a few days, after which the problem returned.

The dialler I installed was Right Dialler from Goodwy.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .