I'm having problem connecting my Samsung Galaxy Y GT-S5360 to the computer using via USB.

Whenever I connect it, it automatically charges. Before there was a prompt to connect it to the computer but now it just charges directly. I have tried downloading the Samsung Kies but it still won't connect.


5 Answers 5


When I experience this, turning the phone off and on again with the USB connected seems to make it work.

I recommend you turn it on and off again.


2 places to check:

  1. Settings -> Wireless and Network -> USB Settings, and select "Ask on connection".

  2. Settings -> Applications -> Development -> USB debugging [disable USB debugging]

  • Which version(s) of Android do these work for?
    – david6
    Dec 30, 2012 at 1:59
  • 1
    I can confirm it works Upto Gingerbread.
    – kn330
    Dec 30, 2012 at 7:43
  • Thanks. I get prompted (for MTP or PTP) when I plug in an SGS3 Mini (with 4.1.1). It connects (but does not work) under Nautilus/Ubuntu 12.10. But for my Samsung Tab2 7.0 tablet (with 4.0.3) I have no USB settings (except enable/disable debugging). My PC does not even detect the device attached.
    – david6
    Dec 30, 2012 at 9:18
  • Oh! This post has some solutions : askubuntu.com/questions/43086/…
    – kn330
    Dec 30, 2012 at 13:50
  • I've tried most of these. They don't seem very stable ,and do not generally work for Samsung devices.
    – david6
    Dec 31, 2012 at 20:57

You might have a broken cable and/or connector:

Install aLogCat and unplug the USB cable then clear the logs, then re-plug the USB cable. You should see something like this:

--------- beginning of /dev/log/system
D/Vold    (  132): USB connected
D/Vold    (  132): Share method ums now available
I/StorageNotification(  263): UMS connection changed to true (media state mounted)
D/Vold    (  132): USB connected
D/Tethering(  185): sendTetherStateChangedBroadcast 1, 0, 0
D/Tethering(  185): interfaceAdded :usb0
D/BluetoothNetworkService(  185): updating tether state
D/BluetoothNetworkService(  185): interface usb0
W/Tethering(  185): active iface (usb0) reported as added, ignoring
D/dalvikvm(  580): GC_EXPLICIT freed 6K, 53% free 2705K/5639K, external 0K/0K, paused 57ms
D/dalvikvm(  639): GC_EXPLICIT freed 24K, 51% free 2814K/5639K, external 0K/0K, paused 61ms

If it's just something like this, your connection is not detected (broken cable,...):

D/SettingsAppWidgetProvider(  639): Widget is from a previous version... Let's update
D/SettingsAppWidgetProvider(  639): No instances yet... Wait for at least one instance to exist before adding global settings
D/dalvikvm(  263): GC_CONCURRENT freed 332K, 49% free 3079K/6023K, external 911K/990K, paused 4ms+3ms
D/dalvikvm(  639): GC_EXPLICIT freed 17K, 51% free 2814K/5639K, external 0K/0K, paused 60ms

Just slide downwards and tap "USB Connected". From there, you'll see the "Connect USB storage" button. Just tap it, and wait for the android image to change from green to orange. Now, you're connected.


Try removing and reinserting your SD card.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .