I saw Tasker on my friend's phone and I tried out a simple profile.

I wanted the Camera button to vibrate the phone. Nothing more, nothing less. The setup is as follows:

Button: Camera

  • Priority: Highest
  • Stop Event: Checked

Then the task only has 1 action and that is:


  • Time: 200

With the above, I couldn't get the profile to work. When I hold down the Camera button app, it still proceeds to open the Camera app. I tried creating other profiles other than the Button: Camera and they all worked. I want to know if there's something I'm missing here?

EDIT: I also realized that the "USB Plugged" action is not firing. It keeps staying on "Not USB Plugged" mode even if we have the data cable connected to a PC already.

EDIT 2: The device I'm doing this on is an Xperia Mini.

  • 1
    first, you do not need to modify priority (except in rare cases). It does not describe the "importance", you can rather compare it to the Linux nice command. Second, a stop event usually is not needed either (Tasker simply reverts to the previous state if the condition is no longer met). Third, the "plugged" stuff works for me (at least with my docking station) -- so it might be device specific, and you didn't specify your device. Last but not least, bug reports are better filed with the projects bug tracker :) – Izzy Jul 13 '12 at 8:37
  • Well I'm not entirely sure if it's a bug or something I'm overlooking? As for the priority, I simply followed a tutorial about some example Tasker profiles. – Propeller Jul 13 '12 at 10:09
  • yeah, priority is one of the ambigous things about Tasker. As for your example: I cannot see anything missing. Maybe you update your question with some device info? I'd say it's a device-specific issue, especially after your edit concerning "USB plugged". Could even be so specific as only valid for your single device; is USB fully working aside from this Tasker issue (charging, connecting as mass storage...)? – Izzy Jul 13 '12 at 10:40
  • Yep, USB is fully working. I got around this problem already, instead of using "USB plugged", I simply used power source instead but unfortunately, the Camera button issue still exist. – Propeller Jul 14 '12 at 20:32
  • I'd recommend contacting the developer for that. Hint: You could use an app like aLogCat to get some more details: Install it, run it, then press the Camera-Button, and finally export the captured log segment. Send that along your report to the developer, which increases the chances for a solution. – Izzy Jul 14 '12 at 23:24

Okay so it has dawned on me that the reason why the shutter action on Tasker doesn't seem to work. It seems to be the stock ROM I was using before. Now that I'm using an AOSP rom, it works quite flawlessly. So yeah, it might have been the rom.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.