I've got a Samsung Galaxy Nexus running stock Android Jelly Bean 4.1.1. As you probably know, Jelly Bean has a new feature that allows you to "respond-by-SMS" to incoming phone calls. Unfortunately, this feature sends a text message from your "real" phone number instead of Google Voice. For those of us that use Google Voice full-time, and don't want to reveal our real phone numbers, and keep accurate messaging logs, this is undesirable behavior.

Question: Does anyone know if it's possible to get the respond-by-SMS feature to send from Google Voice instead of the built-in Messaging app?

The description of the feature in question is: "When you miss a call, a new notification lets you return the call or reply by SMS with a single touch."


2 Answers 2


You should be able to go to Settings>Manage Applications>All Applications>

Go to your MMS.apk, and reset the defaults.

So long as you already have Google Voice installed on your phone, The next time you try to use this feature, it should ask you which one you want to use.

But IDK- No JB love on the HTC Sensation, yet.

  • I'll give this a shot. Jul 16, 2012 at 16:22
  • The button to clear defaults is greyed out for the Messaging application. Jul 16, 2012 at 21:01

I found a simple but amazingly effective workaround solution: Any.Do for Android. Install it from Google Play.

How it works for me:

  1. Decline incoming call
  2. A missed call popup will appear from Any.Do. Choose the Send Text option
  3. I think the first time you use it, you have to choose default app. Here's where you choose Google Voice and, bam, you are all set!

You can create custom default messages as well within Any.Do.

Hope this helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .