I've been having an issue with my apps where an error "Package file is invalid" keeps appearing. I read a tutorial somewhere which told me to "uninstall updates" for the Google Play Store application. I was told doing this would uninstall the application, and then the device would automatically reinstall Google Play Store.

I did this, restarted my phone, but the application never reappeared.

I think tried downloading an .apk file to install this manually, but on install the application wouldn't load.

Has anyone done this before? How can I reinstall this application? I believe I need it for all future downloads and updates to my applications.

For the record, my phone is not rooted.

  • Do you still have the old Android Market installed? If you just uninstalled the updates, then there probably is an older version of the store at your phone which is also probably why you can't reinstall the Play Store.
    – Propeller
    Commented Jul 23, 2012 at 8:46
  • @ShedoSurashu No I don't have the old market installed I don't think. I can't find "Market" or "Google Play Store" in my applications.
    – Curtis
    Commented Jul 23, 2012 at 9:33
  • Alas, if only you were rooted, you can simply go to /system/apps/ and see if "Vending.apk" is there. :/
    – Propeller
    Commented Jul 23, 2012 at 9:42

8 Answers 8


I nearly did everything offered in all google searches. nothing works successfully for google play to work in HCL ME U1. Installing Android SDK and running ADB shell etc. also sometime does not allow files to be copied to the /system/app folder and it's very tedious thing if you are not familiar with java and linux commands.

There seems to be some restriction by HCL in startup for disabling google play. Following is the option which worked for me and very easy and using which so far I have installed about 100 applications from google play and using my HCL ME U1 without any problem.

  1. Install JDK in PC. You may also require HCL ME connect for drivers of HCL U1.

  2. Install Android commander (PC program. download and install from net)

  3. Using android commander Copy android apk file in /system/app folder. Also copy the same apk to SD card folder.

  4. Now when you restart the tab it read as 'android upgrading', but soon you will get message "Unfortunately google play stopped working". Then try open Google Play it will show an error "unfortunately google stopped working" again.

  5. Now go to you SD card where you have the Google Play .apk

  6. Double tap on that and install Google Play. It will give a message that you are replacing main application etc. Say ok.

  7. Now Google Play will work/download/install any application from marketplace. Now Google Play will work like anything.

  8. The moment you shutdown or reboot your tab you will start getting "Unfortunately google play stopped working" message again.

  9. So whenever you want to use google play double tap and install Google Play from sd card. For that time being it will work until you reboot or shutdown and start.

So use that way it hardly takes 5-6 seconds to install Google Play .apk from sdcard whenever you start the tab.

PLEASE NOTE it is very important that to have the android .apk in root of /system/app folder. Without that it will not work.

--- What I feel is that HCL has made some restriction by disabling something in startup. Anyway it takes only 5 seconds to install Google Play .apk from sdcard. And for that time it works just pefect. I tried all other way but this is the only way it works.


You cannot uninstall the PlayStore/GoogleMarket app without having your device rooted -- so as Shedo guessed, you probably just uninstalled the latest update. Which means, the original app included with your firmware takes over -- and probably is called "Market" (the original name of the Playstore, before some market specialists started toying with the name).

So look out for an icon with a green bag, labeled "Market", that's it. Go ahead and start it, browse a bit, leave it. The Play Store App should be forced back on your device automatically -- maybe not immediately, but it usually doesn't take long.

  • Hi, thanks for your response. I can't find "Market" under my applications :S Any other ideas?
    – Curtis
    Commented Jul 23, 2012 at 9:17
  • Check all the apps in your drawer: is there really none with a "green bag" icon? Maybe it's called "Google Market" or something like that (it may be localized and depending on your locale/language settings). Is your device rooted? How did you remove the app?
    – Izzy
    Commented Jul 23, 2012 at 9:28
  • The only "green bag" icon I can see is "HTC Hub" (I'm using a HTC Sensation). I removed it by going to something like "Settings > Applications > All > Google Play Store > Uninstall updates". And nope its not rooted, and I'm running Android 4
    – Curtis
    Commented Jul 23, 2012 at 9:31
  • OK -- in that case, as said above (and as the button suggested), you did NOT uninstall the app itself, but "Uninstall(ed) updates" only. The original ROM-App must still be there: Simply the availability of the "Uninstall updates" button indicates it is a system app you cannot remove. Sure you checked the app drawer? What launcher are you using? Maybe you a) checked the wrong tab (some drawers devide apps in "All", "Recent", and "Running" -- so if you checked in "Recent", the uninstall may have removed it there), or b) the drawer might be hiding it?
    – Izzy
    Commented Jul 23, 2012 at 9:48
  • I'm looking under "All Apps" and there is neither "Market" or "Google Play Store". I've searched through them all and I cannot find anything which would be related to the market app. I appreciate what you're saying, but I cannot find the app anywhere :/ I'm worried I'm going to need to do a full system restore :(
    – Curtis
    Commented Jul 23, 2012 at 9:59

I could never find a way of recovering my Google Play Store, and had to do a full restore.

After the full restore my Google Play Store returned.


Go to this site and you can download "unofficial" version of Google apps. Make sure you choose a right one, which is based on your phone's display spec and version.

  • Ha, just realized that you may have to have a rooted phone to install such downloaded gapps.
    – Narayanan
    Commented Jul 23, 2012 at 13:12
  • 2
    Not may -- must. As I just learned: An app which wants to install other apps must either be signed with the same certificate as the ROM -- or must be moved to the /system partition. As the former is quite unlikely, the latter must be achieved; which is impossible without root. To sum up: You neither can successfully install nor uninstall Google Market without having your device rooted.
    – Izzy
    Commented Jul 23, 2012 at 18:58
  • Can the down voter leave a comment on in what way the answer can be improved?
    – Narayanan
    Commented Aug 8, 2012 at 13:23

I have an update for you that fixed my problem with Google Play Store not opening.

I did something (god knows what?!?!?!) and the Google Play Store wouldn't work. Every time I clicked on it, it opened then within a second it shut again.

I didn't want to reset the device (Google Nexus 7) and found an option called "Reset app preferences". If you go into Settings > Apps then in the top right hand corner click the 3 dots that sit under the current time. The option is listed here.

I'm not sure what else it does but the Google Play Store then opened first time and I also now have listed "Google Play Services" which wasn't listing before.

Hope this helps some people as it was doing my head in trying to work it out!


I had the same problem. I uninstalled the updates, as I was receiving multiple errors (insufficient storage available, package file invalid, etc.) when I was trying to download a particular app. I was about to restore my phone, so I removed my SD card (I'm not really sure if that's necessary), and when I checked my phone, Play Store icon was still there. I just clicked it and there was a message that Android Market just needs to be updated. Just hit "Continue" and you'll be able to open it again. I also tried to download the app I was having trouble with from Play Store without the SD card, it worked!

Good thing that it worked, as I was even thinking of rooting my device but I'm not sure how.


Go to Settings, look for Google Play Store, and uninstall updates.

  • 2
    Very unlikely. Please read the question again: OP said to have deleted the app -- so what "updates" shall be there to uninstall?
    – Izzy
    Commented Mar 30, 2013 at 19:03

I uninstall google play store on my samsung galaxy ace 2X and I figured it out how to recover the google play store...step1)go to settings 2)application manager 3)press "ALL" then scroll down and find the apps for "Google Play Store"....then click on "ENABLE"

  • 1
    If you can still find it in apps, you did not uninstall it but simply disabled it. That's something completely different than having the .apk deleted.
    – Izzy
    Commented Mar 24, 2013 at 9:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .