On my Nexus 7, I keep getting

An error occurred. Please try again.

Over and over when attempting to buy any paid apps on the Google Play store. It works fine for free apps, but always returns this same error when I try to buy a paid app. I've "tried again" a dozen times with the same result.

google play paid purchase click -- an error occurred. please try again

I checked my Google account and the Nexus 7 shows up as properly attached to my account. It also works OK in Mail, Calendar, and the other bundled Google apps on the device.

I don't understand why I'm getting this error, which tells me nothing. I'd like to buy some Android apps for my Nexus 7, but I can't!

Based on one of the comments, I tried buying the same app on the Google Play website, and I get an odd message next to the Nexus 7 (which does show up in the list of devices for me):

You have not opened the Google Play Store app recently on this device. Please open it and try again.

You have not opened the Google Play Store app recently on this device. Please open it and try again.

But, but, but I have the Google Play store open right now on my device!

  • 7
    Have you tried purchasing using the web site in your desktop browser? That might reveal a more descriptive (or at least different) error message. Commented Jul 24, 2012 at 17:18
  • 4
    Do you have Google Wallet setup? This could cause an odd error.
    – Robin
    Commented Jul 24, 2012 at 17:19
  • It may be some maintenance error, sometimes it has happened to me even with free apps. I recommend to wait an hour or two and try again.
    – user969757
    Commented Jul 24, 2012 at 17:30
  • Any chance you're rooted? Seems like some similar cases of this are solved by installing a different version of the Play Store, but you'd need root to try that (example). Commented Jul 24, 2012 at 18:54
  • not rooted, all default, has been consistently happening since I got it for about a week. Commented Jul 24, 2012 at 21:02

5 Answers 5


According to this thread on code.google.com (from April 2012), it seems that one user solved a similar issue after they were advised to turn off 2 step auth to use Google Play:

I'm having same issue & tech just advised I have to turn off 2 step verification to get into Play.

So I would disable 2 step auth on the Google account associated with the device and try again. (If that doesn't work, I wonder if it's even worth trying a factory reset with 2 step auth turned off...)

BTW: That thread is in the issues list for source code behind the Google Authenticator Application. The issue is not actually related to that application, however, after setting up 2 step auth the user reportedly could not access Google Play so that is why they blamed that app.

Alternatively (still assuming 2 step auth is part of the issue), you could create an app-specific password for Google Play as described in this answer. Quoting that answer:

  1. Create an app-specific password for Google Play at https://accounts.google.com/IssuedAuthSubTokens (E.g., name it "Android Phone Play Store").

  2. On the phone, add a 2nd Google account (All Settings > Accounts & sync).

  3. Launch Google's Play Store.

  4. Go to Menu > Accounts.

  5. Switch account; then, switch back.

  6. When it asks for a password, enter the app-specific password you've created.

  • I am definitely using 2-factor auth, so this is possible Commented Jul 25, 2012 at 4:06
  • @JeffAtwood did the latter work for you?
    – jrg
    Commented Aug 29, 2012 at 20:09
  • @jrg have not had time to check but seems the most plausible explanation Commented Aug 30, 2012 at 3:06
  • I experienced a problem with 2-factor when factory resetting a device (HTC Incredible with Gingerbread). Upon entering Google account info, I would get an error (until I turned off 2-factor auth). So it seems reasonable that 2-factor could cause an issue with the (market) account on a new device.
    – gary
    Commented Aug 30, 2012 at 12:42

In order of least to most destructive.

  1. clear data on market app, reboot
  2. remove your google account, reboot, add it again
  3. clear data from google framework services (this is similar to above, in that it will log you out, but I'm not sure what else this clears), reboot, sign back in.

the 3rd one was what finally fixed it for me and I haven't had the issue again.

  • excellent! how exactly do I do #3 in your list though? Eldar's answer covers #1, and #2 is pretty simple. Commented Jul 24, 2012 at 17:51
  • 1
    @JeffAtwood: Look for "Google Framework Services" in the Settings->Apps list. Commented Jul 24, 2012 at 18:10
  • @eldar well, I went to "Google Framework Services" in apps, cleared data for that app, rebooted the tablet and... same error unfortunately. Going to have to try more stuff. Commented Jul 24, 2012 at 18:29

I recall seeing a post on RootzWiki where someone was seeing a very similar issue, though on a Galaxy Nexus. Specifically, he had the following symptoms:

To my dismay I found that I get an error no matter what I try to buy. Free apps seem to work fine.

The solution he ultimately ended up finding was:

Got it! Found a tweet from Peter Alfonso stating to uninstall the market updates and clear cache.

To do this, go into Settings->Apps, swipe left to the "All" tab, then select the Play Store (it should be titled "Google Play Store" so look in the 'G' area) and press Uninstall Updates. Once that's finished, hit Clear cache, or Clear data if you want to wipe all of its data completely. Once you've done that, relaunch the Play Store and try to purchase the app again.

  • this is great, but I don't see any "Uninstall Updates" on the Google Play Store app info page. I see: Clear Data, Clear Cache, Clear Defaults. I'll try clearing cache and data now. Commented Jul 24, 2012 at 17:49
  • Done, then rebooted tablet, same error unfortunately. Commented Jul 24, 2012 at 17:49
  • 1
    @JeffAtwood: It's possible that the N7 ships with the most recent version of Play, then, so there's actually no updates to uninstall. Commented Jul 24, 2012 at 17:49

I just had this problem on my Nexus 7, though error message was Authentication is required. You need to sign into your Google Account, but same symptoms, everything worked fine except for downloading paid apps.

The problem was Google Wallet was disabled. To protect your data and privacy, your Apps Google Wallet account will be suspended when your account password is reset by your Google Apps administrator. Which was news to me and the root cause. I had to ring them to renable Wallet, then Google Play started working again for paid apps.


Issue reported on Google:

[#4319215] Paid apps are not available in territories

Payment and buying apps/in-app items -> [#4319215] Paid apps are not available in territories

We’ve received reports that some users living in a territory don’t have access to the same Android apps on Google Play as that territory’s parent country. You may be experiencing this issue if:

  • You live in a non-sovereign geographic region or a country subdivision
  • You’re receiving error messages when trying to purchase Android apps on Google Play or you don’t see paid apps on Google Play at all (you’re only seeing free apps)

There is no workaround available right now, but we’ll continue to update this page with developments, so check back soon.

Issue first reported on: February 1, 2012
Last updated on: July 3, 2012

Are you on a territory? If not, consider reporting your issue at Google Staff.

  • I am in the USA, so far as I know, that is not a territory? Commented Jul 25, 2012 at 0:45
  • @JeffAtwood Dono.. hence me asking! Don't really understand how the "map" gets divided where you are :) (Portugal here)
    – Zuul
    Commented Jul 25, 2012 at 0:47
  • @JeffAtwood Here for certain things, like telecommunications, we're divided by territories..
    – Zuul
    Commented Jul 25, 2012 at 0:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .