4

My Galaxy S2 (ICS I9100G) connects to my home wifi but sometimes does not actually transmit data. I took it to the shop and they did a factory reset (which I could have done on my own) and then was told to take it home and see if it was any better. It wasn't.

O2 tech support didn't really have much to offer so I tried various different online fixes. None worked.

We got another router (for the back of the house) which used WPA2 whereas the initial router uses WPA. My SGS2 works absolutely fine on this new router.

What's going on?

  • 1
    Thanks for coming forward to share your knowledge. It will be more useful if you can strip the solution from your question and post it as an answer (answering your own question is very well acceptable). This will promote this question from "unanswered" to "answered". – Narayanan Jul 25 '12 at 11:03
  • Yeah cause im new to this part of stack exchange I need to wait like 8 hours or something – andrewktmeikle Jul 25 '12 at 11:25
  • You can answer any time, you don't need an account for that even. Answering should just work. – ce4 Jul 25 '12 at 15:26
  • @ce4: Very new users (with less than 10 reputation) have these sorts of restrictions placed on them to help prevent spamming. That includes self-answering. – ale Jul 25 '12 at 19:20
  • @AlEverett: Ah, self-answering is the key here. Thank you for the hint. Andrew: You got 11 rep, so it should be possible now :-) – ce4 Jul 25 '12 at 20:32
3

My solution was to change the front room wifi to WPA2 to match the backroom's wifi (WPA2) which I never had a problem with.

Don't know why this works I cannot believe the SGS2 has less than optimum support for WPA. Maybe it was buggy software ... although I am fully updated and have been since I got the phone. (September 11)

I should mention this was not a problem caused by ICS or fixed by the firmware upgrade as I had the problem pretty much as soon as I got the phone (September 11).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.