I have a new Samsung Galaxy S3 that plays well with my wireless network at home and elsewhere but has major connectivity issues with the wireless network in my office. Nobody else has problems and I never had problems when I used to have an iPhone. I don't want to get into the technical details of the network setup, I just want to know what things I can try to fix this. It acts like it has a strong connection and the up and down green arrows seem to blink when they are supposed to, but apps seem to have intermittent connectivity at best. I've tried changing all the advanced settings under "Advanced Wi-Fi" and even tried going into service mode and disabling Wi-Fi power saving. Anything else I can try?

1 Answer 1


I have my own Galaxy S3 and I found that this solution worked great for me:

  1. Go to your GS3’s dialer and dial *#0011#

  2. Now you have to hit the left menu button when you see the “service mode” screen

  3. Choose WiFi

  4. Turn off the “WiFi power save mode” button if its on

  5. Now exit this menu. Turn off and turn on your WiFi. Re-enter the network info if you have already entered it before.

  • 4
    Thanks for your answer, Agnes! But could you please include the basic details from the linked page? We like to have at least the basic details included with the answers: in case the linked page becomes unavailable, your answer could still stay useful then.
    – Izzy
    Sep 17, 2012 at 9:43
  • 1
    What's the difference with that and going into Settings > Wireless & Networks > Wifi, tap menu, tap on Advanced > Wifi Sleep Policy...?
    – t0mm13b
    Sep 22, 2012 at 17:21
  • and does this code also work for S4?
    – roxan
    Dec 5, 2013 at 3:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .