My Nexus S is running the stock "soju" build of ICS from Google (build IMM76D). However, I have not seen the OTA update for Jelly Bean. Am I running the wrong version? Do I need to change some settings? Or should I expect the device to see the update soon?


You can try forcing your device to ask for a free download slot:

  1. Settings > Apps > All
  2. Find Google Service Framework in the list, tap on it
  3. First tap Clear Data, then Force Stop

After this procedure the last checked date under Settings > About Phone > System Update should have been reset to 1970 or so. Tap the Check now button there and see if the update notification pops up now.

If this fails even after multiple tries, you can follow a slightly longer procedure described in this post, which involves taking out the SIM card.

Apart from that, you could just wait (you'll definitely get the update with your current config) or flash it manually.

  • I tried that; it still didn't see the update. – Zifre Jul 30 '12 at 16:30
  • As I said, just a try not a guarantee although many users had success after doing this procedure multiple times. But, as the other comment points out, the rollout also depends on your carrier because Google doesn't roll it out at the same time all over the world but rather carrier by carrier. But there're definitely users with Nexus S on AT&T who got the update: erik.thauvin.net/blog/posts/3981/… – kremalicious Jul 30 '12 at 18:35
  • Okay I followed the instructions in that guide, and it worked. I think removing the SIM was what caused it to work. (I suggest putting the link in your answer so more people will see it.) – Zifre Jul 31 '12 at 0:12
  • good suggestion, added another short paragraph with the link. Have fun with Jelly Bean – kremalicious Jul 31 '12 at 0:30

My hunch is that you will indeed see the update eventually; I think the schedule depends on your carrier.

If you're impatient, you can download it directly from http://android.clients.google.com/packages/ota/google_crespo/9ZGgDXDi.zip, although I confess I was never able to get that to apply; you might also try downloading the entire 4.1 image and running the "flash-all" script; that worked for me on previous releases and thus I assume it'll work for you: https://dl.google.com/dl/android/aosp/soju-jro03e-factory-c9f5a67d.tgz

  • Why should it depend on my carrier? It's the stock Google image so I thought it got updates from Google. (It's on an AT&T prepaid plan if that matters.) – Zifre Jul 30 '12 at 16:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.