I have an Asus Nexus 7 tablet, and was trying to connecting it in MTP (Media Transfer Protocol) mode to my Samsung Series 5 laptop running Windows 7 SP1 Home Premium Edition. I have a bunch of Android development tools installed also, and typically have my devices connected using the ADB (Android Debug Bridge) driver.

When I first attempted to connect my Nexus 7 to my laptop to use in MTP mode, it simply refused to show up in Windows Explorer. Finally, I figured out that I had to uninstall the ADB device ("Android Phone") from Device Manager and then it would work correctly in MTP mode.

Any ideas why this is? Is MTP mode trumped by the ADB USB Driver?

Note: I always had USB Debugging disabled on the Nexus 7, so it wasn't that.

2 Answers 2


Although I'm surprised it didn't work in Windows 7 out of the box (it worked on my PC) there is a way to fix it.

Please open C:\Windows\inf\wpdmtp.inf in Notepad and add following

; Nexus 7
%GenericMTP.DeviceDesc%=MTP, USB\MS_COMP_MTP
%GenericMTP.DeviceDesc%=MTP, USB\VID_18D1&PID_4E42&MI_00

In two places - at the end of sections [Generic.NTx86] and [Generic.NTamd64]

This method will also work on Windows 7 after installing Windows Media Player 11.

  • 1
    your answer really helped me to resolve the MTP issue. It did not work at the beginning, because my PID was sligtly different, it is 4E41 and I had to remove the > &MI_00 from the end. Now my nexus works like a charm :P
    – iwan.z
    Commented Oct 1, 2012 at 17:19

I've had some trouble myself hooking up my nexus 7 with a windows 7 computer, even though I'd figure the device is new, Windows would be able to locate and download drivers itself.

Its probably some conflict between the two, have you tried first installing the ADB driver after installing the nexus 7 as an MTP device?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .