I just moved our network access point to a different subnet (which has a different default gateway). After the change, all the laptop computers adjusted without much issue (some XP computers needed the "repair" option run on the connection). However, none of the Android phones have Internet access anymore. They can connect to the wireless access point without a problem, but they can't access the Internet. This only seems to happen on the Android phones. I am wondering if maybe it remembers the old settings and isn't picking up the new default gateway? What can I do to fix this?

  • 1
    I was able to fix the problem by changing the DNS servers my DHCP was serving up. Its kind of weird since the servers (local) work fine for the desktop and laptop clients. Only the android phones didn't like them. – Daniel Aug 1 '12 at 17:24
  • 1
    If that's what fixed the issue for you, you should write that as an answer and then "accept" it. This way it can act as a signpost for future readers with a similar issue. – ale Aug 1 '12 at 17:37
  • I will, but since I only have 6 rep, I can't for another 5 hours. – Daniel Aug 1 '12 at 17:43

Turns out it was a problem with the DNS servers my DHCP was serving up. The first two were local DNS servers. I don't know why they weren't working for android (they worked fine for the laptop computers), but as soon as I replaced the second local DNS server with a remote DNS server, things started working. It also appears that android only pays attention to the first two servers given by DHCP since I had other servers listed after my local server.

It seems kind of fishy that only the android phones had problems with the local DNS server. I wouldn't mind finding out what the underlying problem is, but changing the DNS servers is an acceptable workaround.

| improve this answer | |

Most likely, the device is still hanging out to the old network configuration and needs to be adjusted or cleared. There are a couple of methods that can be used to accomplish this. Lets start from the simplest:

  1. Reset the device Wi-Fi connection.

    Simple Wi-Fi connection reset, by turning off wireless and then turning it back on:

    1. Tap the Menu button on your device;
    2. Tap "Settings";
    3. Tap "Wireless and Network";
    4. Tap "Wi-Fi settings";
    5. In the new screen, uncheck Wi-Fi to turn it off;
    6. After Wi-Fi is turned off, tap the entry again to turn it back on.

    Test your connection to confirm if this worked. If not, continue to the next options.

  2. Forget about the network

    You can have your device forget the network and then re-add it, but for this to be possible, it needs to get out of range of the network, then:

    1. From the previous location, long press the network you want to forget;
    2. Tap over "Forget Network";
    3. Get back within range, wait for the network to show up;
    4. Enter the network password to join.

    At this point your device should have a new address and be working.

  3. Advanced Wi-Fi settings

    At this point is clear that you need to confirm all settings for your Wi-Fi connection:

    1. Tap the Menu button on your device;
    2. Tap "Settings";
    3. Tap "Wireless and Network";
    4. Tap "Wi-Fi settings";
    5. Tap the Menu button again;
    6. Tap "Advanced";

    From here you can confirm all the settings one by one and make sure they match your network requirements:

    Use static IP address, Network Gateway, Netmask, DNS1 and DNS2.

| improve this answer | |
  • I already tried all of the above. I was finally able to fix the problem by messing with the DNS servers my DHCP was offering (seem comment on question). I think there is still some under-lying problem, but the DNS fix will work for now. – Daniel Aug 1 '12 at 17:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.