I installed "android x86 4.0 rc1 asus_laptop iso" on /sda3 (NTFS partition created in Windows 7) of my Advent Verona recently. I already run Windows 7 and Linux Mint 11 so was dual booting with GRUB.

When I installed Android it took over the Mint bootloader and would not show Mint in its bootloader, but I was able to correct the problem, thereby getting the Mint loader back, through this site.

However, this caused Android to disappear from the bootloader. I tried to get it to appear so I could load it from there and was able to do so using this information.

I've been able to edit the file that makes you see all the OS on the laptop and I see all the three OSes now. I can load into Windows 7 and Linux Mint without problems but when I try to boot Android I get these errors on a black page:

[numbers] VFS: could not find a valid V7 on sda3
[numbers] kernel panic - not syncing: vfs: unable to mount root fs on unknown block (8.3)
[numbers] Pid. 1 comm: swapper not Tainted 3.0.8 android x86 asus_laptop

Then it reboots after a few seconds. What am I not doing right?

  • 1
    think this question is more of a fit for superuser as its governing bootloader and grub....
    – t0mm13b
    Commented Aug 2, 2012 at 22:58
  • 1
    I'm inclined to say that this is alright here for now. Although Super User would likely take it as well, this is probably a pretty standard procedure for anyone who wants to install Android x86 in a multiboot configuration. The answer may well lie in the GRUB config, but I think that just creates overlap with SU here and doesn't necessarily make this off-topic for us. Commented Aug 3, 2012 at 13:38
  • 1
    There's this: webupd8.org/2012/03/…
    – ale
    Commented Aug 3, 2012 at 15:36

2 Answers 2


The one thing that sticks out from your question is that /sda3 is NTFS-formatted

on /sda3 (NTFS partition created in Windows 7)

and thus the Android's Linux kernel panic's due to not understanding NTFS.


I have a similar issue and excluded the posibility that NTFS is the problem since I tried everything on a FAT32 partition.

I think it has something to do with the drive geometry not being aligned properly thus the errors. (in my situation, everything else (OSes) work fine)

  • This should be comment rather than an answer.
    – roxan
    Commented Sep 26, 2012 at 17:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .