I've been trying to send an MMS on a rooted ST17i with the MiniCMSandwich Lite rom but for some reason, I can't send any MMS (no matter how big). It will just say "SENDING" on the messaging app but would stay that way for quite some time (probably around 30 minutes) then it would say that sending has failed. So far, I've already tried the following combinations:

  • wifi: on
  • data: on
  • wifi: off, data: off
  • wifi: on, data: on

All to no avail. It just won't send. However, I can browse the web without any problems using my data plan (no wifi) and I have assumed that data and MMS are somewhat tied together in a way. So since data is working (it's even on an HSDPA status based on my signal bar), why won't MMS work?

I guess it should be also beneficial that I state that sending MMS worked when I was still on stock. As for my service provider, I'm under a postpaid plan from Sun Cellular. My APN settings is as follows:

Name: Sun MMS
APN: mms
Proxy: Not set
Port: Not set
Username: Not set
Password: Not set
Server: Not set
MMSC: http://mmscenter.suncellular.com.ph
MMS proxy:
MMS port: 9201
MCC: 515
MNC: 05
Authentication type: Not set
APN type: mms
APN protocol: IPv4
APN enabled/disable: APN enabled
Bearer: Unspecified
  • 2
    You could check Androids logcat (aLogcat is a nice app to help you with that) while sending an MMS. First start aLogCat, and advise it to write the protocol to your SD-Card. Then send your MMS. Later, stop aLogCat and check for errors. Within the app itself you can filter. This might help you to indicate the source of your problem.
    – Izzy
    Aug 3, 2012 at 18:04

2 Answers 2


As I don't use MMS, I had to check first: Looks like MMS have a APN configuration separate from your (normal) internet APN. Here are some useful ressources:

Quoting from the t-mobile link:

When you receive errors trying to send picture messages (MMS) or access data or the internet, confirm your Android phone is set up correctly. This is usually a problem with device settings.

Which seems to confirm my initial suspicion :)

So if you let us know your provider, plus your current APN configuration, maybe we can give more detailled help. On the other hand, the easiest was would be asking your carrier for the correct APN data directly (or visit his website, where they are probably held available -- as my examples from O2 and t-mobile show). A Google-Search (for " mms apn") could also prove useful.

  • I actually have the APN settings already set up for MMS. As far as I know, this APN setup is the same one I used while I was still on stock and it worked quite perfectly well before. I'll update the original question with my APN settings and provider.
    – Propeller
    Aug 4, 2012 at 4:04
  • Good point. You can verify your settings at Sun Cellular (interactive setup guide), maybe they changed something. I also found example settings here, which look close to yours.
    – Izzy
    Aug 4, 2012 at 17:30

Just to add closure to this question, I finally resolved it by downloading an Mms.apk from a different AOSP ICS build rom. It seems the one that came with the rom I'm using has some issues. Using the Mms.apk from another rom fixed it for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .