0

I mostly use my computer for email, but obviously when I'm on the go it's good to have my email accessible at all times. That's what the email app is for, right?

So I have it set up to download emails, but to never delete them from the server. Essentially this is the same as I have on my laptop. Only my main computer is set to delete emails from the server when I delete them from my inbox.

The point is, while this works fine on my laptop, my phone will keep downloading the same emails, even when I hit the "Delete" button to remove them from my phone's inbox. Strangely, though, it will only do this a few hours after they were deleted (the mailbox is set to update every 15 minutes), and usually only when I receive a new email or two.

In other words, when I get a new email, the phone will start downloading some old emails seemingly at random.

What gives, and how do I fix it?

2

There are multiple approaches to this problem. The first an most effective is to switch from POP3 (which I assume from your question you are using) to IMAP, where mail is handled on the server instead of client-side -- so you can delete a message when you decide to delete it (and not when client X is retrieving it, as handled by POP3).

Second might be trying a different mail client (again, I do not know what you are currently using). For Android, I'd recommend K-9 Mail -- which is capable of handling POP3 as well as IMAP, and even Exchange (the latter via WebDAV).

  • Thanks, it seems to be working better already. I had the two running side-by-side for a little while, and when K-9 downloaded a new email, the pre-installed app downloaded one from three months ago. – Niet the Dark Absol Aug 6 '12 at 0:22
  • Yepp, K-9 is great -- I use it for about 2 years now without any issues. Glad it could help you as well! – Izzy Aug 6 '12 at 6:05
0

I use a Samsung Galaxy SIII and Outlook and have had the same problem. My approach (at Godaddy's suggestion) was to change the Advanced settings in Outlook email account settings (in the Outlook Tools menu) so that email is left on the server even after delivery (one check box) but deleted after so many days (another check box) and/or deleted after the email is deleted from Trash (a third check box). Then I make sure to delete my trash on the phone after I have downloaded whatever I want to save on my computer copy of Outlook.

0

I think i have the solution to the problem. When setting up your email untick the push notification you then get a manual button, from there you can manually input incoming and outgoing settings. In the incoming settings there is a delete email from server, click the WHEN I DELETE FROM INBOX. From then on you will be able to delete from your phone to the server. HTH. Now the only problem is you can't set the the sync schedule.

  • I don't seem to have this option on my phone. I can set synching to Never, or every 15, 20 or 60 minutes. There is no Manual push in Gmail that I can see. – Brian Springthorpe Mar 12 at 12:29
0

I just found the easiest way to solve this problem, completely by accident. Open your email app and click on settings; then click on the words "clear cache." That is it. Problem solved!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.