After one of the latest updates (not sure if it was the last one or a previous one) of the Google Play app, I am having an error trying to update a large app (42MB). It says:

Error Downloading . There is insufficient space on the device.

My device is a Samsung P1000 running Froyo. It's rooted, but the error was there before rooting it.

A quick Google search showed several Samsung users having the same problem (the app in question that was giving me the headache is Smurf's village). Some said that removing the updates to the Android Market (Google Play) app would fix it, but to me it was of no avail.

I also tried the procedure in this Google help FAQ to no avail.

Now I am stuck with a prehistoric version of the Market (that works on small apps) and still cannot update Smurf's Village or install big apps. How can I fix this?

EDIT: device has over 2GB of internal SD storage, 27GB of external SD card, so space is not an issue.

  • Sorry for not stating it, but the device has no lack of free space. Commented Aug 6, 2012 at 12:03

3 Answers 3


For me, it was all about killing and rebuilding a bigger cache. I want it registered on SE so other people having the same problem can find an answer googling for it.

The problem seems to be with the size of the partition the cache is in. It is mounted on a 20-30MB partition in the phone internal SD card.

The fix that worked to me was described in this blog post.

THE BLOCK BELOW IS TAKEN FROM Jimmy Halim's blog post, and used with his permission.

After browsing around, I found out that the cache folder (that I assume used by the market) is using small partition (around 20mb in my case). So to solve this we need to change it to bigger partition.

You gonna need Android Terminal Simulator or equivalent terminal app. This will also require your Android rooted.

Type su (root permission request will be shown: you need to approve it).

Type cd /

Type umount /cache

Type mount -o rw,remount -t rootfs rootfs / (to set the folder access to rw – read write)

Type rmdir /cache (delete cache folder). I personally using root explorer to do point 5-6.

Type mkdir /sdcard/cache

Type ln -s /sdcard/cache /cache (to link cache folder to /sdcard/cache – which should have bigger partition size)

My p1000 was rooted and had terminal emulator and busybox installed. I just typed the commands in the order described by Jimmy Halim (kudos to him).

Searching for the background to this question, I also found this forum post (in portuguese) that seems to (untested by me) solve the problem using an app.

[begin portuguese posting]

Para solucionar o problema, eu precisei modificar o tamanho do cache do telefone

[end portuguese posting]

  • What about the poor souls who don't already have terminal emulator or busybox installed. They can't install them, because they can't install anything.
    – Urbycoz
    Commented Aug 29, 2014 at 14:21
  • @Urbycoz If you can't install anything, that is stuff for another related question. I only had problems installing LARGE apps. Emulator and Busybox are tiny compared to today's apps. Also, someone could ask "What about non-rooted devices" and the answer would be the same: It is stuff for another Q&A. Commented Sep 2, 2014 at 12:46
  • If a user couldn't install anything at all, they could always enable USB debugging and do everything through ADB. Commented May 3, 2015 at 23:38

Can you check how much space is left in internal storage of your device? You can do that by going to Settings->Applications->Storage Use and see how much is free space in internal storage. If the value is less that what the app needs (i.e. 42 Mb) then it means that you have to free up some space before installing.

To free up:

  1. Best is to visit the app list and remove unwanted one, starting with the one that occupies more space.
  2. Move the heavy apps to SD Card. Though I suspect this could be possible only from GingerBread onwards and not in your Froyo.
  • 2
    3. while walking the app list, deleting the cache of apps when it's too big. Maybe only a temporary solution, but better than nothing.
    – Izzy
    Commented Aug 6, 2012 at 6:21
  • 1
    My p1000 has plenty of storage, both internal and external. It is an issue with the cache itself, I was able to solve it for my (ROOTED) android. Still on the lookout for a solution to the cache size that does not require rooting. Commented Aug 6, 2012 at 12:07
  • The OP said that there was enough space...
    – frandroid
    Commented Oct 27, 2014 at 21:11
  • Why o why I cannot add an answer to this question? Anyway, finally found a solution for this - uninstall update from Google play app
    – Elia Weiss
    Commented Apr 1, 2016 at 12:03

Just to add some other things to try if @Mindwin's answer doesn't work for you:

1) Delete your logs located in /data/log.

  • You can do this by either going to the recovery menu and deleting the logs (if the option is available for you, it isn't for every phone). Or if you have a rooted phone you can run rm -r in this folder from a terminal emulator.

2) If you can install apps, the SD Maid app can remove any lingering cache or apk files that are sometimes left over after removal.

3) If your phone is a Samsung Galaxy, you can dial *#9900# from the dial screen and then choose the second option: "Delete Dumpstate/logcat".


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .