I've been a happy owner of an Acer Iconia A500 for a bit over a year now but a couple of weeks ago it started to complain about its internal memory being full. I was a bit surprised as I keep movies, and such on the external SD card but I assumed is was some browser cache, Maps or so which had eaten up a fair chunk of the 32G memory it has internally.

However, that doesn't seem to be the case. I have cleared the data of almost every single App I have installed but still if I look at the Storage tab of the settings I see the following (a couple of hours ago):

700M+643M+0.2M+64M+98M is clearly not 27G

I get the feeling that the rightmost grey part of the bar should be a bit more than 379MB(the Available part)... (SD Card at the bottom of the picture is the external one, never mind that one).

I've tried almost every disk usage app available out there and they all show similar results, the following is DiskView (picture taken after I removed a few apps):

DiskView output

(in this picture "SD Card" is the internal one...)

One thing all the disk usage apps seems to have in common is that unless the device is rooted, they cannot see what is in some directories (like /data) which makes me think it is either Android itself (4.0.3 on this device) which has some kind of cache which is misbehaving or that some process is producing extreme amounts of logs somewhere.

Sorry for this long intro, but the basic question is: How do I proceed?

I guess one alternative is to find what is worth backing up and do a factory reset or something but I wold really like to find out what happened first.

Rooting it is an alternative which would probably help me find out more but I sort of like it as it is (except for this issue). If it is needed to resolve it I could of course do it but it feels like you shouldn't have to with an appliance like this.

Is there another way forward? I have this naive hope that there is a button somewhere I haven't seen that clears all logs or reduce the log level from debug to info.

Edit: One thing I've been considering but cannot investigate is if it could be cores. I've had a lot of crashes lately (presumably because it has been running low on disk).
In response to Izzy's comment below. Apps adds up to more or less exactly the 700MB listed as "Apps" (seems to be the total of data and the apps themselves).

  • let us continue this discussion in chat
    – Fredrik
    Commented Aug 6, 2012 at 21:52
  • For finding where my storage is going, I like DiskUsage. It has no trouble digging into the /data directory. (Which is how I know most of my storage is being used by cached Google Music files.)
    – ale
    Commented Aug 9, 2012 at 13:48
  • @AlEverett It sees the same files as the others. Whatever this is, it is something outside what a non-rooted device gives you access to.
    – Fredrik
    Commented Aug 10, 2012 at 5:44

4 Answers 4


This looks like the Acer GPS-log leak we had on an Acer Iconia A200:

The bottom line is that when the GPS is used, the GPS driver for ICS 4.0.3 on the Acer A-series tablets apparently writes numerous gl-YYYY-MM-DD-HHMMSS.txt files into the /data/gps directory. The files are apparently not automatically deleted, and so over time will consume most of the internal storage space.

Users can not delete these files without root access. However, there is a patch to clear the GPS log data (no root access needed, so no warranty voided).

  • download the patch from the Acer drivers site (to your desktop)
  • unzip and copy the contained Update.zip from it to an empty, FAT32 formatted microSD card. (We uploaded it to an already present card in the connected tablet, which wasn't empty, but it still worked.)
  • (Re)start the tablet with the microSD card in it, while holding the “Volume Down” key until a message appears in the upper left corner of the screen.
    (Something like Erasing cache before SD update...; I interpret this message as: "erase and update", so it should cure the symptom and the cause.)
    The tablet will continue to start up afterwards (less than a minute), and you will be good to go.

There is a nice .pdf in the download, describing the above steps in detail with (screen)shots. (It also talks about an accompanying user_cleanGPSlog text file, but we didn't have it and did not seem to need it.)

  • Thank you! You're not saying anything about it so I assume the upgrade is relatively safe to do and will normally not wipe the tablet?
    – Fredrik
    Commented May 27, 2013 at 21:25
  • @Fredrik: the documentation does not mention wiping any data (but the logs) and we did not notice anything getting removed. But my friend (I am sort of the involuntary system administrator...) mainly uses it for browsing and gaming, so there is no major storage of media, etc. going on. (And of course we already removed a lot of cache, data and apps, before finding the cause and the patch). However, I do not know all the data that could have been stored/lost, so I can't tell for sure. But it looked pretty safe. Commented May 28, 2013 at 7:30

Here are some key points to this problem. Though not all of them applied in this case, I will still include all of them -- as in another case they might prove helpful:

  • A good starting point to check is apps -> manage apps in Androids system menu, which lists all apps+data and can be sorted by size, to identify the "biggest consumers". While here, you can "delete" too-big caches (per app)
  • some directories in the file system cannot be investigated without having root privileges, so the preferred du -k|sort -n (to find the biggest files) would e.g. skip directories below /data
  • still, having a terminal emulator available (Android Terminal Emulator would be a good candidate), at least a df -h could show where free space goes toward zero (see screenshot below). In case the -h parameter ("human readable") is not understood on your system, you might try to replace it by -m ("megabytes"), -k ("kilobytes"), or omit it completely.
  • The article Debugging Android core dumps describes "core dumps" under Android are called "Tombstones", and stored globally as /data/tombstones/tombstone_nn, with "nn" simply being a counter. As many crashes were reported, this might be a place "filling up" (see below). But only 2.5MB could be located here in this case.
  • According to Android Forensics by Andrew Hoog, it might be worth diving into /data/local: The “/data/local” directory is important as it allows shell (the user account nonrooted phones run adbd as) read/write access. When an app is installed, it is first copied to “/data/local.” Which means, even on non-rooted devices one should be able to dig in here.
  • SD Maid - System cleaning tool might find some more orphans -- but without root access, this apps capabilities are limited.
  • If the "big egg" cannot be found and removed, one can either start to uninstall some apps, cleaning "big data" from others (see first step), or, as a last resort, there always remains the factory-reset which should clean up everything -- but be aware: all your downloaded apps and all your data (on internal storage only, of course -- SD card will not be affected) will get removed as well when you do this.
  • if still unable to solve the issue, a last resort is a factory reset. But before doing that it would be good to be prepared for the next time, so one last chance are a few steps immediately before the factory reset:
    1. backup as much data/apps as you need and can
    2. switch to airplane mode -- the market must not know what we are doing now
    3. one by one, uninstall your apps (for system apps which cannot be uninstalled: uninstall their updates, clear cache and data). After each uninstall, check your free space for unexpected "big jumps". If such a "jump" happens: Note the app uninstalled at this place -- it has to be a/the evil one. Continue if it still doesn't make up for the missing space
    4. when finished with the last one, go to the "point of no return", pull the plug, do the factory reset. It's over now ;(
    5. after the reboot, re-configure your "virgin device" with your original market account data (you remember them hopefully?). As we made sure the market stood uninformed of our actions from step 2 on, you should now be able to re-sync your apps and some data. The apps for sure, the data only provided you synced them with the market before step 2.
    6. keep an eye on the "evil app(s)", if you detected any at step 3. You may want to remove these (now or later).

The following screenshot shows the output of df -h on a Motorola Droid 2. As you can see, there are 2 mount points on internal storage which could be candidates for "getting filled": /data (the most likely -- and got the hit in this case) plus /cache. The command was executed without root privileges:

ls -l output on a Motorola Droid 2

Tombstones: The folder's location is /data/tombstones. Permissions of the /data directory are drwxrwxr-x, the tombstones subdirectory has drwxr-xr-x -- so they are accessible also on non-rooted devices. Using a terminal emulator (see above), you can cd /data/tombstones and do a ls -l to see whether there are any tombstones, and what size they occupy. Unfortunately, all tombstones are owned by system, and permissions are set to rwx------ -- so if that's your troublemaker: you cannot remove them without root :( Have a good backup (huh? how, without root?), and probably a factory-reset will be your last resort...

  • Seems like /data is where it is all used... 26 out of 27G used... Currently 467M free... I just need to figure out with what :-)
    – Fredrik
    Commented Aug 6, 2012 at 21:39
  • Just come over and join, I've created a room: chat.stackexchange.com/rooms/4403/tombstones
    – Izzy
    Commented Aug 6, 2012 at 22:00
  • Thanks for all the good pointers... I didn't really get anywhere except closer to realizing a real backup and a factory reset is probably my best bet. Thanks again.
    – Fredrik
    Commented Aug 7, 2012 at 19:40
  • You are very welcome! Before doing the reset it would be good to figure out which app was "guilty". For this, I'd recommend: Airplane Mode (to keep the market uninformed), then uninstall all apps one-by-one and check everytime for "signs and portents". With some luck you figure out -- for the next time. Due to the "uninformed market" you should be able to "simply resync your apps + some data" after the factory reset, as the market does not know about the uninstalls.
    – Izzy
    Commented Aug 7, 2012 at 21:29
  • @Fredrik I updated my answer with the steps proposed in my last comment. You might want to check the item with the numbered list within.
    – Izzy
    Commented Aug 7, 2012 at 21:39

I had this same problem with my Acer A100 tablet and found the source of the problem: there's a folder located in /data/gps that fills up with txt files. Mine was 4.3G. If your device is rooted, you can delete them from a terminal emulator or adb and reclaim your space:

$ su
# cd /data/gps
# rm gl-*.txt
  • Thanks, I wasn't rooted so it wouldn't have helped me then. Good to know for the future though...
    – Fredrik
    Commented Oct 10, 2012 at 19:23
  • Yeah, if you're not rooted, the only option is to do a factory reset. You can temporarily root and then revert back, too. The hardest part of rooting is probably getting the ADB driver installed and working on your computer. Commented Oct 15, 2012 at 3:50
  • I rarely use GPS on mine but after reading this I used ES File Explorer I found a file named data/GPS and found hundreds or possibly a thousand files that showed 0 data so I deled them all and went from approximately 300Mb. of free space to over 4 gigs of free space.
    – user25157
    Commented Dec 17, 2012 at 20:40
  • Dan, it doesn't matter if you make use of the GPS or not: this particular device seems to just collect files in that folder regardless. Commented Feb 11, 2013 at 5:41
  • @Dan: there is a patch from Acer. See my answer Commented May 28, 2013 at 14:16

First delete the .thumbnail folder within your DCIM directory, then switch of the device and turn back on. This solved the problem for me.

  • 1
    I think the thumbnails was one of the first things I deleted. Unfortunately it didn't eat up much of those missing 30G.
    – Fredrik
    Commented Nov 14, 2012 at 12:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .